summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.14.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.14.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.14.bb b/meta/recipes-devtools/go/go_1.14.bb
new file mode 100644
index 0000000000..5d40cf9d04
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.14.bb
@@ -0,0 +1,14 @@
1require go-${PV}.inc
2require go-target.inc
3
4export GOBUILDMODE=""
5
6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips/riscv
7# doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its
8# variants.
9python() {
10 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
12 else:
13 d.setVar('GOBUILDMODE', 'pie')
14}