summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.14.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.14.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/go/go_1.14.bb b/meta/recipes-devtools/go/go_1.14.bb
index bc90a1329e..76ff788238 100644
--- a/meta/recipes-devtools/go/go_1.14.bb
+++ b/meta/recipes-devtools/go/go_1.14.bb
@@ -3,12 +3,12 @@ require go-target.inc
3 3
4export GOBUILDMODE="" 4export GOBUILDMODE=""
5export CGO_ENABLED_riscv64 = "" 5export CGO_ENABLED_riscv64 = ""
6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips/riscv 6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but
7# doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its 7# windows/mips/riscv doesn't support -buildmode=pie, so skip the QA checking
8# variants. 8# for windows/mips/riscv and their variants.
9python() { 9python() {
10 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True): 10 if 'mips' in d.getVar('TARGET_ARCH') or 'riscv' in d.getVar('TARGET_ARCH') or 'windows' in d.getVar('TARGET_GOOS'):
11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel") 11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
12 else: 12 else:
13 d.setVar('GOBUILDMODE', 'pie') 13 d.setVar('GOBUILDMODE', 'pie')
14} 14}