diff options
Diffstat (limited to 'meta/recipes-devtools/go/go-runtime_1.9.bb')
-rw-r--r-- | meta/recipes-devtools/go/go-runtime_1.9.bb | 23 |
1 files changed, 0 insertions, 23 deletions
diff --git a/meta/recipes-devtools/go/go-runtime_1.9.bb b/meta/recipes-devtools/go/go-runtime_1.9.bb deleted file mode 100644 index d5279ea897..0000000000 --- a/meta/recipes-devtools/go/go-runtime_1.9.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | require go-${PV}.inc | ||
2 | require go-runtime.inc | ||
3 | |||
4 | export GO_TARGET_INSTALL = "std" | ||
5 | export CC_FOR_TARGET = "${CC}" | ||
6 | export CXX_FOR_TARGET = "${CXX}" | ||
7 | |||
8 | do_compile() { | ||
9 | export GOBIN="${B}/bin" | ||
10 | export TMPDIR="$GOTMPDIR" | ||
11 | export CC=$BUILD_CC | ||
12 | |||
13 | cd src | ||
14 | CGO_CFLAGS="${BUILD_CFLAGS}" CGO_LDFLAGS="${BUILD_LDFLAGS}" ./make.bash --host-only | ||
15 | cp ${B}/pkg/tool/${BUILD_GOTUPLE}/go_bootstrap ${B} | ||
16 | rm -rf ${B}/pkg/${TARGET_GOTUPLE} | ||
17 | ./make.bash --target-only | ||
18 | if [ -n "${GO_DYNLINK}" ]; then | ||
19 | cp ${B}/go_bootstrap ${B}/pkg/tool/${BUILD_GOTUPLE} | ||
20 | GO_FLAGS="-buildmode=shared" GO_LDFLAGS="-extldflags \"${LDFLAGS}\"" ./make.bash --target-only | ||
21 | fi | ||
22 | cd ${B} | ||
23 | } | ||