summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-dep_0.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.5.4.bb')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.5.4.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.5.4.bb b/meta/recipes-devtools/go/go-dep_0.5.4.bb
deleted file mode 100644
index 0da2c6607c..0000000000
--- a/meta/recipes-devtools/go/go-dep_0.5.4.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
9 file://0001-bolt_riscv64-Add-support-for-riscv64.patch;patchdir=src/github.com/golang/dep \
10 "
11SRC_URI_append_riscv64 = " file://0001-Update-sys-module-to-latest.patch;patchdir=src/github.com/golang/dep "
12
13SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b"
14
15inherit go
16
17# New Go versions has Go modules support enabled by default and cause the Glide
18# tool build to fail.
19export GO111MODULE = "off"
20
21GO_INSTALL = "${GO_IMPORT}/cmd/dep"
22
23RDEPENDS_${PN}-dev += "bash"
24
25BBCLASSEXTEND = "native nativesdk"
26
27# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
28# error message: vet config not found
29PTEST_ENABLED_mips = "0"
30PTEST_ENABLED_mips64 = "0"