summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-dep_0.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.5.4.bb')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.5.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.5.4.bb b/meta/recipes-devtools/go/go-dep_0.5.4.bb
new file mode 100644
index 0000000000..ead87870e2
--- /dev/null
+++ b/meta/recipes-devtools/go/go-dep_0.5.4.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
9 "
10
11SRCREV = "1f7c19e5f52f49ffb9f956f64c010be14683468b"
12
13inherit go
14
15GO_INSTALL = "${GO_IMPORT}/cmd/dep"
16
17RDEPENDS_${PN}-dev += "bash"
18
19BBCLASSEXTEND = "native nativesdk"
20
21# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
22# error message: vet config not found
23PTEST_ENABLED_mips = "0"
24PTEST_ENABLED_mips64 = "0"