diff options
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.5.0.bb')
-rw-r--r-- | meta/recipes-devtools/go/go-dep_0.5.0.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.5.0.bb b/meta/recipes-devtools/go/go-dep_0.5.0.bb new file mode 100644 index 0000000000..f0ce60a8ec --- /dev/null +++ b/meta/recipes-devtools/go/go-dep_0.5.0.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Dependency management tool for Golang" | ||
2 | HOMEPAGE = "https://github.com/golang/dep" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" | ||
5 | |||
6 | GO_IMPORT = "github.com/golang/dep" | ||
7 | SRC_URI = "git://${GO_IMPORT} \ | ||
8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ | ||
9 | " | ||
10 | |||
11 | # Points to 0.5.0 tag | ||
12 | SRCREV = "224a564abe296670b692fe08bb63a3e4c4ad7978" | ||
13 | |||
14 | inherit go | ||
15 | |||
16 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" | ||
17 | |||
18 | RDEPENDS_${PN}-dev += "bash" | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
21 | |||
22 | # for x86 ends with textrel in ${PN} | ||
23 | # http://errors.yoctoproject.org/Errors/Details/185630/ | ||
24 | # ERROR: QA Issue: ELF binary '/work/i586-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep/usr/bin/dep' has relocations in .text [textrel] | ||
25 | INSANE_SKIP_${PN} += "textrel" | ||
26 | |||
27 | # for aarch64 ends with textrel in ${PN}-ptest | ||
28 | # http://errors.yoctoproject.org/Errors/Details/185632/ | ||
29 | # ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep-ptest/usr/lib/go-dep/ptest/github.com/golang/dep/cmd/dep/dep.test' has relocations in .text [textrel] | ||
30 | INSANE_SKIP_${PN}-ptest += "textrel" | ||