summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-dep_0.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.3.2.bb')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.3.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.3.2.bb b/meta/recipes-devtools/go/go-dep_0.3.2.bb
new file mode 100644
index 0000000000..627324a1df
--- /dev/null
+++ b/meta/recipes-devtools/go/go-dep_0.3.2.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-use-a-smaller-constant-that-hopefully-works-the-same.patch;patchdir=src/github.com/golang/dep \
9 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
10 "
11
12# Points to 0.3.2 tag
13SRCREV = "8ddfc8afb2d520d41997ebddd921b52152706c01"
14
15inherit go
16
17GO_INSTALL = "${GO_IMPORT}/cmd/dep"
18
19RDEPENDS_${PN}-dev += "bash"