diff options
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.20.11.bb')
-rw-r--r-- | meta/recipes-devtools/go/go-binary-native_1.20.11.bb | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.20.11.bb b/meta/recipes-devtools/go/go-binary-native_1.20.11.bb new file mode 100644 index 0000000000..bf91067971 --- /dev/null +++ b/meta/recipes-devtools/go/go-binary-native_1.20.11.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. | ||
2 | |||
3 | SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" | ||
4 | HOMEPAGE = " http://golang.org/" | ||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" | ||
7 | |||
8 | PROVIDES = "go-native" | ||
9 | |||
10 | # Checksums available at https://go.dev/dl/ | ||
11 | SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" | ||
12 | SRC_URI[go_linux_amd64.sha256sum] = "ef79a11aa095a08772d2a69e4f152f897c4e96ee297b0dc20264b7dec2961abe" | ||
13 | SRC_URI[go_linux_arm64.sha256sum] = "7908a49c6ce9d48af9b5ba76ccaa0769da45d8b635259a01065b3739acef4ada" | ||
14 | SRC_URI[go_linux_ppc64le.sha256sum] = "e04676e1aeafe7c415176f330322d43a4be5ea6deb14aca49905bd1449dc7072" | ||
15 | |||
16 | UPSTREAM_CHECK_URI = "https://golang.org/dl/" | ||
17 | UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" | ||
18 | |||
19 | CVE_PRODUCT = "go" | ||
20 | |||
21 | S = "${WORKDIR}/go" | ||
22 | |||
23 | inherit goarch native | ||
24 | |||
25 | do_compile() { | ||
26 | : | ||
27 | } | ||
28 | |||
29 | make_wrapper() { | ||
30 | rm -f ${D}${bindir}/$1 | ||
31 | cat <<END >${D}${bindir}/$1 | ||
32 | #!/bin/bash | ||
33 | here=\`dirname \$0\` | ||
34 | export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" | ||
35 | \$here/../lib/go/bin/$1 "\$@" | ||
36 | END | ||
37 | chmod +x ${D}${bindir}/$1 | ||
38 | } | ||
39 | |||
40 | do_install() { | ||
41 | find ${S} -depth -type d -name testdata -exec rm -rf {} + | ||
42 | |||
43 | install -d ${D}${bindir} ${D}${libdir}/go | ||
44 | cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ | ||
45 | |||
46 | for f in ${S}/bin/* | ||
47 | do | ||
48 | make_wrapper `basename $f` | ||
49 | done | ||
50 | } | ||