summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-binary-native_1.14.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.14.6.bb')
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.14.6.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.14.6.bb b/meta/recipes-devtools/go/go-binary-native_1.14.6.bb
new file mode 100644
index 0000000000..694c597a72
--- /dev/null
+++ b/meta/recipes-devtools/go/go-binary-native_1.14.6.bb
@@ -0,0 +1,46 @@
1# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
10SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
11SRC_URI[go_linux_amd64.sha256sum] = "5c566ddc2e0bcfc25c26a5dc44a440fcc0177f7350c1f01952b34d5989a0d287"
12SRC_URI[go_linux_arm64.sha256sum] = "291bccfd7d7f1915599bbcc90e49d9fccfcb0004b7c62a2f5cdf0f96a09d6a3e"
13
14UPSTREAM_CHECK_URI = "https://golang.org/dl/"
15UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
16
17S = "${WORKDIR}/go"
18
19inherit goarch native
20
21do_compile() {
22 :
23}
24
25make_wrapper() {
26 rm -f ${D}${bindir}/$1
27 cat <<END >${D}${bindir}/$1
28#!/bin/bash
29here=\`dirname \$0\`
30export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
31\$here/../lib/go/bin/$1 "\$@"
32END
33 chmod +x ${D}${bindir}/$1
34}
35
36do_install() {
37 find ${S} -depth -type d -name testdata -exec rm -rf {} +
38
39 install -d ${D}${bindir} ${D}${libdir}/go
40 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
41
42 for f in ${S}/bin/*
43 do
44 make_wrapper `basename $f`
45 done
46}