diff options
Diffstat (limited to 'meta/recipes-devtools/gnu-config/gnu-config_git.bb')
-rw-r--r-- | meta/recipes-devtools/gnu-config/gnu-config_git.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gnu-config/gnu-config_git.bb b/meta/recipes-devtools/gnu-config/gnu-config_git.bb new file mode 100644 index 0000000000..0fdee66ba4 --- /dev/null +++ b/meta/recipes-devtools/gnu-config/gnu-config_git.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SUMMARY = "gnu-configize" | ||
2 | DESCRIPTION = "Tool that installs the GNU config.guess / config.sub into a directory tree" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://config.guess;endline=39;md5=0e6ca0501b27177f3bc640f7225e3ead" | ||
6 | |||
7 | DEPENDS_virtclass-native = "perl-native-runtime" | ||
8 | |||
9 | INHIBIT_DEFAULT_DEPS = "1" | ||
10 | |||
11 | SRCREV = "a47f842264fc19837f8a00eb1d2d254a4c527334" | ||
12 | PV = "1.0+git${SRCPV}" | ||
13 | PR = "r0" | ||
14 | |||
15 | SRC_URI = "git://git.sv.gnu.org/config.git;protocol=git \ | ||
16 | file://config-guess-uclibc.patch \ | ||
17 | file://gnu-configize.in" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | do_compile() { | ||
22 | : | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | install -d ${D}${datadir}/gnu-config \ | ||
27 | ${D}${bindir} | ||
28 | cat ${WORKDIR}/gnu-configize.in | \ | ||
29 | sed -e 's,@gnu-configdir@,${datadir}/gnu-config,g' \ | ||
30 | -e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize | ||
31 | # In the native case we want the system perl as perl-native can't have built yet | ||
32 | if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then | ||
33 | sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize | ||
34 | fi | ||
35 | chmod 755 ${D}${bindir}/gnu-configize | ||
36 | install -m 0644 config.guess config.sub ${D}${datadir}/gnu-config/ | ||
37 | } | ||
38 | |||
39 | PACKAGES = "${PN}" | ||
40 | FILES_${PN} = "${bindir} ${datadir}/gnu-config" | ||
41 | |||
42 | BBCLASSEXTEND = "native" | ||