diff options
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.9.bb')
-rw-r--r-- | meta/recipes-devtools/gdb/gdb_7.9.bb | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.9.bb b/meta/recipes-devtools/gdb/gdb_7.9.bb new file mode 100644 index 0000000000..1abc9d8e76 --- /dev/null +++ b/meta/recipes-devtools/gdb/gdb_7.9.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | require gdb.inc | ||
2 | require gdb-${PV}.inc | ||
3 | |||
4 | inherit python-dir | ||
5 | |||
6 | PACKAGECONFIG ??= "" | ||
7 | PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python" | ||
8 | PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace" | ||
9 | |||
10 | do_configure_prepend() { | ||
11 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then | ||
12 | cat > ${WORKDIR}/python << EOF | ||
13 | #!/bin/sh | ||
14 | case "\$2" in | ||
15 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; | ||
16 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; | ||
17 | --exec-prefix) echo "${exec_prefix}" ;; | ||
18 | *) exit 1 ;; | ||
19 | esac | ||
20 | exit 0 | ||
21 | EOF | ||
22 | chmod +x ${WORKDIR}/python | ||
23 | fi | ||
24 | } | ||