summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.7.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.7.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.7.1.bb b/meta/recipes-devtools/gdb/gdb_7.7.1.bb
new file mode 100644
index 0000000000..1abc9d8e76
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.7.1.bb
@@ -0,0 +1,24 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python-dir
5
6PACKAGECONFIG ??= ""
7PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
8PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
9
10do_configure_prepend() {
11 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
12 cat > ${WORKDIR}/python << EOF
13#!/bin/sh
14case "\$2" in
15 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
16 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
17 --exec-prefix) echo "${exec_prefix}" ;;
18 *) exit 1 ;;
19esac
20exit 0
21EOF
22 chmod +x ${WORKDIR}/python
23 fi
24}