diff options
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.bb')
-rw-r--r-- | meta/recipes-devtools/gdb/gdb_7.11.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb new file mode 100644 index 0000000000..ccc33b8656 --- /dev/null +++ b/meta/recipes-devtools/gdb/gdb_7.11.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | require gdb.inc | ||
2 | require gdb-${PV}.inc | ||
3 | |||
4 | inherit python-dir | ||
5 | |||
6 | do_configure_prepend() { | ||
7 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then | ||
8 | cat > ${WORKDIR}/python << EOF | ||
9 | #!/bin/sh | ||
10 | case "\$2" in | ||
11 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; | ||
12 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; | ||
13 | --exec-prefix) echo "${exec_prefix}" ;; | ||
14 | *) exit 1 ;; | ||
15 | esac | ||
16 | exit 0 | ||
17 | EOF | ||
18 | chmod +x ${WORKDIR}/python | ||
19 | fi | ||
20 | } | ||
21 | CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday" | ||