summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb
index ccc33b8656..f02e6431dd 100644
--- a/meta/recipes-devtools/gdb/gdb_7.11.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.11.bb
@@ -1,15 +1,15 @@
1require gdb.inc 1require gdb.inc
2require gdb-${PV}.inc 2require gdb-${PV}.inc
3 3
4inherit python-dir 4inherit python3-dir
5 5
6do_configure_prepend() { 6do_configure_prepend() {
7 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then 7 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
8 cat > ${WORKDIR}/python << EOF 8 cat > ${WORKDIR}/python << EOF
9#!/bin/sh 9#!/bin/sh
10case "\$2" in 10case "\$2" in
11 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; 11 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
12 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; 12 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
13 --exec-prefix) echo "${exec_prefix}" ;; 13 --exec-prefix) echo "${exec_prefix}" ;;
14 *) exit 1 ;; 14 *) exit 1 ;;
15esac 15esac