summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb
new file mode 100644
index 0000000000..ccc33b8656
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.11.bb
@@ -0,0 +1,21 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python-dir
5
6do_configure_prepend() {
7 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
8 cat > ${WORKDIR}/python << EOF
9#!/bin/sh
10case "\$2" in
11 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
12 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
13 --exec-prefix) echo "${exec_prefix}" ;;
14 *) exit 1 ;;
15esac
16exit 0
17EOF
18 chmod +x ${WORKDIR}/python
19 fi
20}
21CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"