summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_6.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_6.4.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_6.4.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_6.4.bb b/meta/recipes-devtools/gcc/gcc_6.4.bb
new file mode 100644
index 0000000000..b0a523cae2
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_6.4.bb
@@ -0,0 +1,15 @@
1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-target.inc
3
4# Building with thumb enabled on armv4t fails with
5# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
7ARM_INSTRUCTION_SET_armv4 = "arm"
8
9do_configure_prepend() {
10 # Easiest way to stop bad RPATHs getting into the library since we have a
11 # broken libtool here
12 sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${S}/libcc1/configure
13}
14
15BBCLASSEXTEND = "nativesdk"