summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.27.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.27.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.27.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.27.bb b/meta/recipes-devtools/file/file_5.27.bb
new file mode 100644
index 0000000000..d1bbf6bc3c
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.27.bb
@@ -0,0 +1,47 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14# Blacklist a bogus tag in upstream check
15UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
16
17SRC_URI = "git://github.com/file/file.git \
18 file://debian-742262.patch \
19 file://0001-Add-P-prompt-into-Usage-info.patch \
20 file://host-file.patch \
21 "
22
23SRCREV = "72da5ae78ed7b5ecbbe84c36ddb493f7907099bc"
24S = "${WORKDIR}/git"
25
26inherit autotools
27
28EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
29EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
30
31FILES_${PN} += "${datadir}/misc/*.mgc"
32
33do_install_append_class-native() {
34 create_cmdline_wrapper ${D}/${bindir}/file \
35 --magic-file ${datadir}/misc/magic.mgc
36}
37
38do_install_append_class-nativesdk() {
39 create_cmdline_wrapper ${D}/${bindir}/file \
40 --magic-file ${datadir}/misc/magic.mgc
41}
42
43BBCLASSEXTEND = "native nativesdk"
44PROVIDES_append_class-native = " file-replacement-native"
45# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
46# depends on file-replacement-native.
47bindir_append_class-native = "/file-native"