summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.18.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.18.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.18.bb b/meta/recipes-devtools/file/file_5.18.bb
new file mode 100644
index 0000000000..d6e7d61d79
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.18.bb
@@ -0,0 +1,36 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-native"
12DEPENDS_class-native = "zlib-native"
13
14SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
15 file://debian-742262.patch \
16 file://file-CVE-2014-9620-and-CVE-2014-9621.patch \
17 "
18
19SRC_URI[md5sum] = "d420d8f2990cd344673acfbf8d76ff5a"
20SRC_URI[sha256sum] = "6519fb706d583231c2419592ebecdbb21d33c62eaf7a1a0b24ddfcb80c08bf07"
21
22inherit autotools
23
24FILES_${PN} += "${datadir}/misc/*.mgc"
25
26do_install_append_class-native() {
27 create_cmdline_wrapper ${D}/${bindir}/file \
28 --magic-file ${datadir}/misc/magic.mgc
29}
30
31do_install_append_class-nativesdk() {
32 create_cmdline_wrapper ${D}/${bindir}/file \
33 --magic-file ${datadir}/misc/magic.mgc
34}
35
36BBCLASSEXTEND = "native nativesdk"