summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.09.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.09.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.09.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.09.bb b/meta/recipes-devtools/file/file_5.09.bb
new file mode 100644
index 0000000000..9b2f3a42af
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.09.bb
@@ -0,0 +1,38 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-native"
12DEPENDS_virtclass-native = "zlib-native"
13PR = "r0"
14
15SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
16 file://fix_version_check.patch \
17 file://dump \
18 file://filesystems"
19
20SRC_URI[md5sum] = "6fd7cd6c4281e68fe9ec6644ce0fac6f"
21SRC_URI[sha256sum] = "bde1c9830ee6c234871778faae8277fdcf775fbb16dea63c8251e24b7c2f869c"
22
23inherit autotools
24
25do_configure_prepend() {
26 cp ${WORKDIR}/dump ${S}/magic/Magdir/
27 cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
28}
29
30FILES_${PN} += "${datadir}/misc/*.mgc"
31
32do_install_append_virtclass-native() {
33 create_cmdline_wrapper ${D}/${bindir}/file \
34 --magic-file ${datadir}/misc/magic.mgc
35}
36
37
38BBCLASSEXTEND = "native"