summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/file/file_5.04.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.04.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.04.bb b/meta/recipes-devtools/file/file_5.04.bb
new file mode 100644
index 0000000000..afc08162d4
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.04.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "File attempts to classify files depending \
2on their contents and prints a description if a match is found."
3HOMEPAGE = "http://www.darwinsys.com/file/"
4SECTION = "console/utils"
5
6# two clause BSD
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
9
10DEPENDS = "zlib file-native"
11DEPENDS_virtclass-native = "zlib-native"
12PR = "r1"
13
14SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
15 file://stringb-compat.patch \
16 file://ge-le.patch \
17 file://dump \
18 file://filesystems"
19
20inherit autotools
21
22do_configure_prepend() {
23 cp ${WORKDIR}/dump ${S}/magic/Magdir/
24 cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
25}
26
27FILES_${PN} += "${datadir}/misc/*.mgc"
28
29BBCLASSEXTEND = "native"