summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb')
-rw-r--r--meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb b/meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb
new file mode 100644
index 0000000000..4edeccfe6d
--- /dev/null
+++ b/meta/recipes-devtools/fakeroot/fakeroot_1.14.4.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Provides a fake \"root environment\" by means of LD_PRELOAD and SYSV IPC or TCP trickery"
2HOMEPAGE = "http://fakeroot.alioth.debian.org/"
3SECTION = "base"
4LICENSE = "GPLv2"
5# fakeroot needs getopt which is provided by the util-linux package
6RDEPENDS = "util-linux"
7RDEPENDS_virtclass-native = "util-linux-native"
8PR = "r0"
9PROVIDES += "virtual/fakeroot"
10
11SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
12 file://absolutepaths.patch"
13
14inherit autotools
15
16do_configure_prepend() {
17 # fakeroot's own bootstrap includes other autoreconf stuff we don't need here
18 # so manually create the aux directory
19 mkdir -p ${S}/build-aux
20}
21
22do_install_append() {
23 install -d ${D}${STAGING_INCDIR}/fakeroot/
24 install -m 644 *.h ${D}${STAGING_INCDIR}/fakeroot
25}
26
27# Compatability for the rare systems not using or having SYSV
28python () {
29 if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
30 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
31}
32
33BBCLASSEXTEND = "native"