summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect/expect_5.45.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/expect/expect_5.45.bb')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
new file mode 100644
index 0000000000..3278e0f7ef
--- /dev/null
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -0,0 +1,51 @@
1DESCRIPTION = "expect."
2HOMEPAGE = " http://expect.nist.gov"
3LICENSE="GPLv3+"
4SECTION = "devel"
5
6LIC_FILES_CHKSUM = "file://README;md5=2862a5993e5f43b368a49cfaad5bead6"
7PR = "r1"
8DEPENDS = "tcl"
9RDEPENDS_${PN} = "tcl"
10ALLOW_EMPTY_${PN} = "1"
11
12FILESEXTRAPATHS_prepend := "${THISDIR}/expect:"
13
14S = "${WORKDIR}/${BPN}${PV}"
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/5.45/expect5.45.tar.gz \
17 file://0001-configure.in.patch \
18 file://0002-tcl.m4.patch \
19 "
20EXTRA_OECONF += "--includedir=${STAGING_INCDIR} \
21 --with-tcl=${STAGING_LIBDIR} \
22 --with-tclinclude=${STAGING_INCDIR} \
23 --enable-shared \
24 --enable-threads \
25 --disable-rpath \
26 "
27EXTRA_OEMAKE_install = " 'SCRIPTS=' "
28FILES_${PN}-dbg += "${libdir}/expect5.45/.debug \
29 ${libdir}/.debug \
30 "
31FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
32 ${STAGING_INCDIR}/expect.h \
33 ${STAGING_INCDIR}/expect_tcl.h \
34 ${STAGING_INCDIR}/expect_comm.h \
35 ${STAGING_INCDIR}/tcldbg.h \
36 ${includedir}/*.h \
37 "
38
39FILES_${PN} += "${libdir}/libexpect${PV}.so \
40 ${libdir}/expect${PV}/* \
41 "
42inherit autotools
43do_install_append() {
44 install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/
45 install -m 0755 ${S}/fixline1 ${D}${libdir_native}/expect${PV}/
46 install -m 0755 ${S}/example/* ${D}${libdir_native}/expect${PV}/
47 rm ${D}${libdir}/expect${PV}/libexpect*.so
48}
49
50SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
51SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"