summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect/expect_5.45.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/expect/expect_5.45.bb')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
new file mode 100644
index 0000000000..3e839a2fe3
--- /dev/null
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -0,0 +1,63 @@
1SUMMARY = "tool for automating interactive applications according to a script"
2DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \
3Following the script, Expect knows what can be expected from a program and what \
4the correct response should be. Expect is also useful for testing these same \
5applications. And by adding Tk, you can also wrap interactive applications in \
6X11 GUIs. An interpreted language provides branching and high-level control \
7structures to direct the dialogue. In addition, the user can take control and \
8interact directly when desired, afterward returning control to the script. \
9"
10HOMEPAGE = "http://sourceforge.net/projects/expect/"
11LICENSE = "PD"
12SECTION = "devel"
13
14LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
15
16DEPENDS += "tcl"
17RDEPENDS_${PN} = "tcl"
18
19inherit autotools-brokensep
20
21SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
22 file://0001-configure.in.patch \
23 file://0002-tcl.m4.patch \
24 file://01-example-shebang.patch \
25 file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \
26 "
27SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
28SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"
29
30S = "${WORKDIR}/${BPN}${PV}"
31
32do_install_append() {
33 install -d ${D}${libdir}
34 install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/
35 install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/
36 install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/
37 rm ${D}${libdir}/expect${PV}/libexpect*.so
38 sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl
39}
40
41EXTRA_OECONF += "--includedir=${STAGING_INCDIR} \
42 --with-tcl=${STAGING_LIBDIR} \
43 --with-tclinclude=${STAGING_INCDIR}/tcl8.6 \
44 --enable-shared \
45 --enable-threads \
46 --disable-rpath \
47 "
48EXTRA_OEMAKE_install = " 'SCRIPTS=' "
49
50FILES_${PN}-dbg += "${libdir}/${BPN}${PV}/.debug \
51 ${libdir}/.debug \
52 "
53FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
54 ${STAGING_INCDIR}/expect.h \
55 ${STAGING_INCDIR}/expect_tcl.h \
56 ${STAGING_INCDIR}/expect_comm.h \
57 ${STAGING_INCDIR}/tcldbg.h \
58 ${includedir}/*.h \
59 "
60
61FILES_${PN} += "${libdir}/libexpect${PV}.so \
62 ${libdir}/expect${PV}/* \
63 "