summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect/expect_5.45.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/expect/expect_5.45.bb')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
new file mode 100644
index 0000000000..970f4a5ccc
--- /dev/null
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -0,0 +1,62 @@
1SUMMARY = "tool for automating interactive applications according to a script"
2DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \
3Following the script, Expect knows what can be expected from a program and what \
4the correct response should be. Expect is also useful for testing these same \
5applications. And by adding Tk, you can also wrap interactive applications in \
6X11 GUIs. An interpreted language provides branching and high-level control \
7structures to direct the dialogue. In addition, the user can take control and \
8interact directly when desired, afterward returning control to the script. \
9"
10HOMEPAGE = "http://sourceforge.net/projects/expect/"
11LICENSE = "PD"
12SECTION = "devel"
13
14LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
15
16DEPENDS += "tcl"
17RDEPENDS_${PN} = "tcl"
18
19inherit autotools-brokensep
20
21SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
22 file://0001-configure.in.patch \
23 file://0002-tcl.m4.patch \
24 file://01-example-shebang.patch \
25 file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \
26 "
27SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
28SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"
29
30S = "${WORKDIR}/${BPN}${PV}"
31
32do_install_append() {
33 install -d ${D}${libdir}
34 install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/
35 install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/
36 install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/
37 rm ${D}${libdir}/expect${PV}/libexpect*.so
38}
39
40EXTRA_OECONF += "--includedir=${STAGING_INCDIR} \
41 --with-tcl=${STAGING_LIBDIR} \
42 --with-tclinclude=${STAGING_INCDIR}/tcl8.6 \
43 --enable-shared \
44 --enable-threads \
45 --disable-rpath \
46 "
47EXTRA_OEMAKE_install = " 'SCRIPTS=' "
48
49FILES_${PN}-dbg += "${libdir}/${BPN}${PV}/.debug \
50 ${libdir}/.debug \
51 "
52FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
53 ${STAGING_INCDIR}/expect.h \
54 ${STAGING_INCDIR}/expect_tcl.h \
55 ${STAGING_INCDIR}/expect_comm.h \
56 ${STAGING_INCDIR}/tcldbg.h \
57 ${includedir}/*.h \
58 "
59
60FILES_${PN} += "${libdir}/libexpect${PV}.so \
61 ${libdir}/expect${PV}/* \
62 "