summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/erofs-utils/erofs-utils_1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/erofs-utils/erofs-utils_1.5.bb')
-rw-r--r--meta/recipes-devtools/erofs-utils/erofs-utils_1.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/erofs-utils/erofs-utils_1.5.bb b/meta/recipes-devtools/erofs-utils/erofs-utils_1.5.bb
new file mode 100644
index 0000000000..b9a97b3e53
--- /dev/null
+++ b/meta/recipes-devtools/erofs-utils/erofs-utils_1.5.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Tools for erofs filesystems"
2# liberofs also available under Apache 2.0
3LICENSE = "GPL-2.0-or-later"
4SECTION = "base"
5LIC_FILES_CHKSUM = "file://COPYING;md5=73001d804ea1e3d84365f652242cca20"
6HOMEPAGE = "https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git/tree/README"
7
8SRCREV = "a2821a66b42aee5430bccee82c280e38d1e9ab29"
9SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git;branch=master"
10
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>(\d+(\.\d+)+))"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "util-linux-libuuid"
16
17inherit pkgconfig autotools
18
19PACKAGECONFIG ??= "lz4"
20PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
21
22EXTRA_OECONF = "${PACKAGECONFIG_CONFARGS} --disable-fuse"
23
24CFLAGS:append:powerpc64le = " -D__SANE_USERSPACE_TYPES__"
25
26BBCLASSEXTEND = "native nativesdk"