summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/files/debian/mips_backend.diff')
-rw-r--r--meta/recipes-devtools/elfutils/files/debian/mips_backend.diff126
1 files changed, 76 insertions, 50 deletions
diff --git a/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff b/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
index 998fa04dc8..697306f82b 100644
--- a/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
+++ b/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
@@ -1,9 +1,62 @@
1From 10a75fd2beefafe2043163f85426d0e575de58d8 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 16 Jul 2010 12:26:46 +0800
4Subject: [PATCH] elfutils: upgrade to version 0.148
5
1Upstream-Status: Pending [from debian] 6Upstream-Status: Pending [from debian]
2Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 7Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
3Index: elfutils-0.175/backends/mips_init.c 8
4=================================================================== 9---
10 backends/Makefile.am | 8 +-
11 backends/mips_init.c | 59 ++++++++
12 backends/mips_regs.c | 104 +++++++++++++
13 backends/mips_reloc.def | 79 ++++++++++
14 backends/mips_retval.c | 321 ++++++++++++++++++++++++++++++++++++++++
15 backends/mips_symbol.c | 53 +++++++
16 libebl/eblopenbackend.c | 2 +
17 7 files changed, 624 insertions(+), 2 deletions(-)
18 create mode 100644 backends/mips_init.c
19 create mode 100644 backends/mips_regs.c
20 create mode 100644 backends/mips_reloc.def
21 create mode 100644 backends/mips_retval.c
22 create mode 100644 backends/mips_symbol.c
23
24diff --git a/backends/Makefile.am b/backends/Makefile.am
25index 5671a32..ba84da6 100644
26--- a/backends/Makefile.am
27+++ b/backends/Makefile.am
28@@ -33,13 +33,13 @@ AM_CPPFLAGS += -I$(top_srcdir)/libebl -I$(top_srcdir)/libasm \
29
30
31 modules = i386 sh x86_64 ia64 alpha arm aarch64 sparc ppc ppc64 s390 \
32- tilegx m68k bpf riscv parisc
33+ tilegx m68k bpf riscv parisc mips
34 libebl_pic = libebl_i386_pic.a libebl_sh_pic.a libebl_x86_64_pic.a \
35 libebl_ia64_pic.a libebl_alpha_pic.a libebl_arm_pic.a \
36 libebl_aarch64_pic.a libebl_sparc_pic.a libebl_ppc_pic.a \
37 libebl_ppc64_pic.a libebl_s390_pic.a libebl_tilegx_pic.a \
38 libebl_m68k_pic.a libebl_bpf_pic.a libebl_riscv_pic.a \
39- libebl_parisc_pic.a
40+ libebl_parisc_pic.a libebl_mips_pic.a
41 noinst_LIBRARIES = $(libebl_pic)
42 noinst_DATA = $(libebl_pic:_pic.a=.so)
43
44@@ -141,6 +141,10 @@ parisc_SRCS = parisc_init.c parisc_symbol.c parisc_regs.c parisc_retval.c
45 libebl_parisc_pic_a_SOURCES = $(parisc_SRCS)
46 am_libebl_parisc_pic_a_OBJECTS = $(parisc_SRCS:.c=.os)
47
48+mips_SRCS = mips_init.c mips_symbol.c mips_regs.c mips_retval.c
49+libebl_mips_pic_a_SOURCES = $(mips_SRCS)
50+am_libebl_mips_pic_a_OBJECTS = $(mips_SRCS:.c=.os)
51+
52 libebl_%.so libebl_%.map: libebl_%_pic.a $(libelf) $(libdw) $(libeu)
53 @rm -f $(@:.so=.map)
54 $(AM_V_at)echo 'ELFUTILS_$(PACKAGE_VERSION) { global: $*_init; local: *; };' \
55diff --git a/backends/mips_init.c b/backends/mips_init.c
56new file mode 100644
57index 0000000..975c04e
5--- /dev/null 58--- /dev/null
6+++ elfutils-0.175/backends/mips_init.c 59+++ b/backends/mips_init.c
7@@ -0,0 +1,59 @@ 60@@ -0,0 +1,59 @@
8+/* Initialization of mips specific backend library. 61+/* Initialization of mips specific backend library.
9+ Copyright (C) 2006 Red Hat, Inc. 62+ Copyright (C) 2006 Red Hat, Inc.
@@ -64,10 +117,11 @@ Index: elfutils-0.175/backends/mips_init.c
64+ 117+
65+ return MODVERSION; 118+ return MODVERSION;
66+} 119+}
67Index: elfutils-0.175/backends/mips_regs.c 120diff --git a/backends/mips_regs.c b/backends/mips_regs.c
68=================================================================== 121new file mode 100644
122index 0000000..44f86cb
69--- /dev/null 123--- /dev/null
70+++ elfutils-0.175/backends/mips_regs.c 124+++ b/backends/mips_regs.c
71@@ -0,0 +1,104 @@ 125@@ -0,0 +1,104 @@
72+/* Register names and numbers for MIPS DWARF. 126+/* Register names and numbers for MIPS DWARF.
73+ Copyright (C) 2006 Red Hat, Inc. 127+ Copyright (C) 2006 Red Hat, Inc.
@@ -173,10 +227,11 @@ Index: elfutils-0.175/backends/mips_regs.c
173+ name[namelen++] = '\0'; 227+ name[namelen++] = '\0';
174+ return namelen; 228+ return namelen;
175+} 229+}
176Index: elfutils-0.175/backends/mips_reloc.def 230diff --git a/backends/mips_reloc.def b/backends/mips_reloc.def
177=================================================================== 231new file mode 100644
232index 0000000..4579970
178--- /dev/null 233--- /dev/null
179+++ elfutils-0.175/backends/mips_reloc.def 234+++ b/backends/mips_reloc.def
180@@ -0,0 +1,79 @@ 235@@ -0,0 +1,79 @@
181+/* List the relocation types for mips. -*- C -*- 236+/* List the relocation types for mips. -*- C -*-
182+ Copyright (C) 2006 Red Hat, Inc. 237+ Copyright (C) 2006 Red Hat, Inc.
@@ -257,10 +312,11 @@ Index: elfutils-0.175/backends/mips_reloc.def
257+ 312+
258+#define NO_COPY_RELOC 1 313+#define NO_COPY_RELOC 1
259+#define NO_RELATIVE_RELOC 1 314+#define NO_RELATIVE_RELOC 1
260Index: elfutils-0.175/backends/mips_retval.c 315diff --git a/backends/mips_retval.c b/backends/mips_retval.c
261=================================================================== 316new file mode 100644
317index 0000000..656cd1f
262--- /dev/null 318--- /dev/null
263+++ elfutils-0.175/backends/mips_retval.c 319+++ b/backends/mips_retval.c
264@@ -0,0 +1,321 @@ 320@@ -0,0 +1,321 @@
265+/* Function return value location for Linux/mips ABI. 321+/* Function return value location for Linux/mips ABI.
266+ Copyright (C) 2005 Red Hat, Inc. 322+ Copyright (C) 2005 Red Hat, Inc.
@@ -583,10 +639,11 @@ Index: elfutils-0.175/backends/mips_retval.c
583+ DWARF and might be valid. */ 639+ DWARF and might be valid. */
584+ return -2; 640+ return -2;
585+} 641+}
586Index: elfutils-0.175/backends/mips_symbol.c 642diff --git a/backends/mips_symbol.c b/backends/mips_symbol.c
587=================================================================== 643new file mode 100644
644index 0000000..261b05d
588--- /dev/null 645--- /dev/null
589+++ elfutils-0.175/backends/mips_symbol.c 646+++ b/backends/mips_symbol.c
590@@ -0,0 +1,53 @@ 647@@ -0,0 +1,53 @@
591+/* MIPS specific symbolic name handling. 648+/* MIPS specific symbolic name handling.
592+ Copyright (C) 2002, 2003, 2005 Red Hat, Inc. 649+ Copyright (C) 2002, 2003, 2005 Red Hat, Inc.
@@ -641,10 +698,10 @@ Index: elfutils-0.175/backends/mips_symbol.c
641+ return ELF_T_NUM; 698+ return ELF_T_NUM;
642+ } 699+ }
643+} 700+}
644Index: elfutils-0.175/libebl/eblopenbackend.c 701diff --git a/libebl/eblopenbackend.c b/libebl/eblopenbackend.c
645=================================================================== 702index d54b720..6cf766f 100644
646--- elfutils-0.175.orig/libebl/eblopenbackend.c 703--- a/libebl/eblopenbackend.c
647+++ elfutils-0.175/libebl/eblopenbackend.c 704+++ b/libebl/eblopenbackend.c
648@@ -71,6 +71,8 @@ static const struct 705@@ -71,6 +71,8 @@ static const struct
649 { "sparc", "elf_sparc", "sparc", 5, EM_SPARC, 0, 0 }, 706 { "sparc", "elf_sparc", "sparc", 5, EM_SPARC, 0, 0 },
650 { "sparc", "elf_sparcv8plus", "sparc", 5, EM_SPARC32PLUS, 0, 0 }, 707 { "sparc", "elf_sparcv8plus", "sparc", 5, EM_SPARC32PLUS, 0, 0 },
@@ -654,34 +711,3 @@ Index: elfutils-0.175/libebl/eblopenbackend.c
654 711
655 { "m32", "elf_m32", "m32", 3, EM_M32, 0, 0 }, 712 { "m32", "elf_m32", "m32", 3, EM_M32, 0, 0 },
656 { "m68k", "elf_m68k", "m68k", 4, EM_68K, ELFCLASS32, ELFDATA2MSB }, 713 { "m68k", "elf_m68k", "m68k", 4, EM_68K, ELFCLASS32, ELFDATA2MSB },
657Index: elfutils-0.175/backends/Makefile.am
658===================================================================
659--- elfutils-0.175.orig/backends/Makefile.am
660+++ elfutils-0.175/backends/Makefile.am
661@@ -33,13 +33,13 @@ AM_CPPFLAGS += -I$(top_srcdir)/libebl -I
662
663
664 modules = i386 sh x86_64 ia64 alpha arm aarch64 sparc ppc ppc64 s390 \
665- tilegx m68k bpf riscv parisc
666+ tilegx m68k bpf riscv parisc mips
667 libebl_pic = libebl_i386_pic.a libebl_sh_pic.a libebl_x86_64_pic.a \
668 libebl_ia64_pic.a libebl_alpha_pic.a libebl_arm_pic.a \
669 libebl_aarch64_pic.a libebl_sparc_pic.a libebl_ppc_pic.a \
670 libebl_ppc64_pic.a libebl_s390_pic.a libebl_tilegx_pic.a \
671 libebl_m68k_pic.a libebl_bpf_pic.a libebl_riscv_pic.a \
672- libebl_parisc_pic.a
673+ libebl_parisc_pic.a libebl_mips_pic.a
674 noinst_LIBRARIES = $(libebl_pic)
675 noinst_DATA = $(libebl_pic:_pic.a=.so)
676
677@@ -141,6 +141,10 @@ parisc_SRCS = parisc_init.c parisc_symbo
678 libebl_parisc_pic_a_SOURCES = $(parisc_SRCS)
679 am_libebl_parisc_pic_a_OBJECTS = $(parisc_SRCS:.c=.os)
680
681+mips_SRCS = mips_init.c mips_symbol.c mips_regs.c mips_retval.c
682+libebl_mips_pic_a_SOURCES = $(mips_SRCS)
683+am_libebl_mips_pic_a_OBJECTS = $(mips_SRCS:.c=.os)
684+
685 libebl_%.so libebl_%.map: libebl_%_pic.a $(libelf) $(libdw) $(libeu)
686 @rm -f $(@:.so=.map)
687 $(AM_V_at)echo 'ELFUTILS_$(PACKAGE_VERSION) { global: $*_init; local: *; };' \