summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/files/debian/mips_backend.diff')
-rw-r--r--meta/recipes-devtools/elfutils/files/debian/mips_backend.diff42
1 files changed, 23 insertions, 19 deletions
diff --git a/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff b/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
index 697306f82b..1097b0ec6f 100644
--- a/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
+++ b/meta/recipes-devtools/elfutils/files/debian/mips_backend.diff
@@ -1,18 +1,19 @@
1From 10a75fd2beefafe2043163f85426d0e575de58d8 Mon Sep 17 00:00:00 2001 1From 68b497668cde5171880d073a7ea50d11c3bddbfc Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 16 Jul 2010 12:26:46 +0800 3Date: Wed, 21 Aug 2019 15:49:52 +0800
4Subject: [PATCH] elfutils: upgrade to version 0.148 4Subject: [PATCH] mips backend
5 5
6Rebase to 0.177
6Upstream-Status: Pending [from debian] 7Upstream-Status: Pending [from debian]
7Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
8 8
9Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9--- 10---
10 backends/Makefile.am | 8 +- 11 backends/Makefile.am | 8 +-
11 backends/mips_init.c | 59 ++++++++ 12 backends/mips_init.c | 59 +++++++++
12 backends/mips_regs.c | 104 +++++++++++++ 13 backends/mips_regs.c | 104 ++++++++++++++++
13 backends/mips_reloc.def | 79 ++++++++++ 14 backends/mips_reloc.def | 79 ++++++++++++
14 backends/mips_retval.c | 321 ++++++++++++++++++++++++++++++++++++++++ 15 backends/mips_retval.c | 321 ++++++++++++++++++++++++++++++++++++++++++++++++
15 backends/mips_symbol.c | 53 +++++++ 16 backends/mips_symbol.c | 53 ++++++++
16 libebl/eblopenbackend.c | 2 + 17 libebl/eblopenbackend.c | 2 +
17 7 files changed, 624 insertions(+), 2 deletions(-) 18 7 files changed, 624 insertions(+), 2 deletions(-)
18 create mode 100644 backends/mips_init.c 19 create mode 100644 backends/mips_init.c
@@ -22,28 +23,28 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
22 create mode 100644 backends/mips_symbol.c 23 create mode 100644 backends/mips_symbol.c
23 24
24diff --git a/backends/Makefile.am b/backends/Makefile.am 25diff --git a/backends/Makefile.am b/backends/Makefile.am
25index 5671a32..ba84da6 100644 26index 91a38e2..aba8a4a 100644
26--- a/backends/Makefile.am 27--- a/backends/Makefile.am
27+++ b/backends/Makefile.am 28+++ b/backends/Makefile.am
28@@ -33,13 +33,13 @@ AM_CPPFLAGS += -I$(top_srcdir)/libebl -I$(top_srcdir)/libasm \ 29@@ -33,13 +33,13 @@ AM_CPPFLAGS += -I$(top_srcdir)/libebl -I$(top_srcdir)/libasm \
29 30
30 31
31 modules = i386 sh x86_64 ia64 alpha arm aarch64 sparc ppc ppc64 s390 \ 32 modules = i386 sh x86_64 ia64 alpha arm aarch64 sparc ppc ppc64 s390 \
32- tilegx m68k bpf riscv parisc 33- tilegx m68k bpf riscv csky parisc
33+ tilegx m68k bpf riscv parisc mips 34+ tilegx m68k bpf riscv csky parisc mips
34 libebl_pic = libebl_i386_pic.a libebl_sh_pic.a libebl_x86_64_pic.a \ 35 libebl_pic = libebl_i386_pic.a libebl_sh_pic.a libebl_x86_64_pic.a \
35 libebl_ia64_pic.a libebl_alpha_pic.a libebl_arm_pic.a \ 36 libebl_ia64_pic.a libebl_alpha_pic.a libebl_arm_pic.a \
36 libebl_aarch64_pic.a libebl_sparc_pic.a libebl_ppc_pic.a \ 37 libebl_aarch64_pic.a libebl_sparc_pic.a libebl_ppc_pic.a \
37 libebl_ppc64_pic.a libebl_s390_pic.a libebl_tilegx_pic.a \ 38 libebl_ppc64_pic.a libebl_s390_pic.a libebl_tilegx_pic.a \
38 libebl_m68k_pic.a libebl_bpf_pic.a libebl_riscv_pic.a \ 39 libebl_m68k_pic.a libebl_bpf_pic.a libebl_riscv_pic.a \
39- libebl_parisc_pic.a 40- libebl_csky_pic.a libebl_parisc_pic.a
40+ libebl_parisc_pic.a libebl_mips_pic.a 41+ libebl_csky_pic.a libebl_parisc_pic.a libebl_mips_pic.a
41 noinst_LIBRARIES = $(libebl_pic) 42 noinst_LIBRARIES = $(libebl_pic)
42 noinst_DATA = $(libebl_pic:_pic.a=.so) 43 noinst_DATA = $(libebl_pic:_pic.a=.so)
43 44
44@@ -141,6 +141,10 @@ parisc_SRCS = parisc_init.c parisc_symbol.c parisc_regs.c parisc_retval.c 45@@ -145,6 +145,10 @@ csky_SRCS = csky_attrs.c csky_init.c csky_symbol.c csky_cfi.c \
45 libebl_parisc_pic_a_SOURCES = $(parisc_SRCS) 46 libebl_csky_pic_a_SOURCES = $(csky_SRCS)
46 am_libebl_parisc_pic_a_OBJECTS = $(parisc_SRCS:.c=.os) 47 am_libebl_csky_pic_a_OBJECTS = $(csky_SRCS:.c=.os)
47 48
48+mips_SRCS = mips_init.c mips_symbol.c mips_regs.c mips_retval.c 49+mips_SRCS = mips_init.c mips_symbol.c mips_regs.c mips_retval.c
49+libebl_mips_pic_a_SOURCES = $(mips_SRCS) 50+libebl_mips_pic_a_SOURCES = $(mips_SRCS)
@@ -699,7 +700,7 @@ index 0000000..261b05d
699+ } 700+ }
700+} 701+}
701diff --git a/libebl/eblopenbackend.c b/libebl/eblopenbackend.c 702diff --git a/libebl/eblopenbackend.c b/libebl/eblopenbackend.c
702index d54b720..6cf766f 100644 703index 01711f5..d0c3589 100644
703--- a/libebl/eblopenbackend.c 704--- a/libebl/eblopenbackend.c
704+++ b/libebl/eblopenbackend.c 705+++ b/libebl/eblopenbackend.c
705@@ -71,6 +71,8 @@ static const struct 706@@ -71,6 +71,8 @@ static const struct
@@ -711,3 +712,6 @@ index d54b720..6cf766f 100644
711 712
712 { "m32", "elf_m32", "m32", 3, EM_M32, 0, 0 }, 713 { "m32", "elf_m32", "m32", 3, EM_M32, 0, 0 },
713 { "m68k", "elf_m68k", "m68k", 4, EM_68K, ELFCLASS32, ELFDATA2MSB }, 714 { "m68k", "elf_m68k", "m68k", 4, EM_68K, ELFCLASS32, ELFDATA2MSB },
715--
7162.7.4
717