summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff')
-rw-r--r--meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff51
1 files changed, 24 insertions, 27 deletions
diff --git a/meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff b/meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff
index 4460d582c7..53fa2f435b 100644
--- a/meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff
+++ b/meta/recipes-devtools/elfutils/files/debian/hppa_backend.diff
@@ -1,4 +1,4 @@
1From 8efad9105b38985bea373416ae8fcacf21d1d129 Mon Sep 17 00:00:00 2001 1From ffb811e18d7046d5bbe54ede5b1b7e14eaac0146 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 21 Aug 2019 15:44:18 +0800 3Date: Wed, 21 Aug 2019 15:44:18 +0800
4Subject: [PATCH] hppa backend 4Subject: [PATCH] hppa backend
@@ -6,15 +6,16 @@ Subject: [PATCH] hppa backend
6Rebase to 0.177 6Rebase to 0.177
7Upstream-Status: Pending [from debian] 7Upstream-Status: Pending [from debian]
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9
9--- 10---
10 backends/Makefile.am | 7 +- 11 backends/Makefile.am | 7 +-
11 backends/libebl_parisc.h | 9 ++ 12 backends/libebl_parisc.h | 9 ++
12 backends/parisc_init.c | 73 ++++++++++++++++ 13 backends/parisc_init.c | 73 +++++++++++++
13 backends/parisc_regs.c | 159 ++++++++++++++++++++++++++++++++++ 14 backends/parisc_regs.c | 159 ++++++++++++++++++++++++++++
14 backends/parisc_reloc.def | 128 ++++++++++++++++++++++++++++ 15 backends/parisc_reloc.def | 128 +++++++++++++++++++++++
15 backends/parisc_retval.c | 213 ++++++++++++++++++++++++++++++++++++++++++++++ 16 backends/parisc_retval.c | 213 ++++++++++++++++++++++++++++++++++++++
16 backends/parisc_symbol.c | 113 ++++++++++++++++++++++++ 17 backends/parisc_symbol.c | 113 ++++++++++++++++++++
17 libelf/elf.h | 11 +++ 18 libelf/elf.h | 11 ++
18 8 files changed, 711 insertions(+), 2 deletions(-) 19 8 files changed, 711 insertions(+), 2 deletions(-)
19 create mode 100644 backends/libebl_parisc.h 20 create mode 100644 backends/libebl_parisc.h
20 create mode 100644 backends/parisc_init.c 21 create mode 100644 backends/parisc_init.c
@@ -24,31 +25,30 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
24 create mode 100644 backends/parisc_symbol.c 25 create mode 100644 backends/parisc_symbol.c
25 26
26diff --git a/backends/Makefile.am b/backends/Makefile.am 27diff --git a/backends/Makefile.am b/backends/Makefile.am
27index 175468f..91a38e2 100644 28index f405212..4755f61 100644
28--- a/backends/Makefile.am 29--- a/backends/Makefile.am
29+++ b/backends/Makefile.am 30+++ b/backends/Makefile.am
30@@ -33,16 +33,19 @@ AM_CPPFLAGS += -I$(top_srcdir)/libebl -I$(top_srcdir)/libasm \ 31@@ -37,7 +37,9 @@ AM_CPPFLAGS += -I$(top_srcdir)/libebl -I$(top_srcdir)/libasm \
31 32 noinst_LIBRARIES = libebl_backends.a libebl_backends_pic.a
32 33
33 modules = i386 sh x86_64 ia64 alpha arm aarch64 sparc ppc ppc64 s390 \ 34 modules = i386 sh x86_64 ia64 alpha arm aarch64 sparc ppc ppc64 s390 \
34- tilegx m68k bpf riscv csky 35- tilegx m68k bpf riscv csky
35+ tilegx m68k bpf riscv csky parisc 36+ tilegx m68k bpf riscv csky parisc
36 libebl_pic = libebl_i386_pic.a libebl_sh_pic.a libebl_x86_64_pic.a \ 37+
37 libebl_ia64_pic.a libebl_alpha_pic.a libebl_arm_pic.a \
38 libebl_aarch64_pic.a libebl_sparc_pic.a libebl_ppc_pic.a \
39 libebl_ppc64_pic.a libebl_s390_pic.a libebl_tilegx_pic.a \
40 libebl_m68k_pic.a libebl_bpf_pic.a libebl_riscv_pic.a \
41- libebl_csky_pic.a
42+ libebl_csky_pic.a libebl_parisc_pic.a
43 noinst_LIBRARIES = $(libebl_pic)
44 noinst_DATA = $(libebl_pic:_pic.a=.so)
45
46+parisc_SRCS = parisc_init.c parisc_symbol.c parisc_regs.c parisc_retval.c 38+parisc_SRCS = parisc_init.c parisc_symbol.c parisc_regs.c parisc_retval.c
47+libebl_parisc_pic_a_SOURCES = $(parisc_SRCS)
48+am_libebl_parisc_pic_a_OBJECTS = $(parisc_SRCS:.c=.os)
49 39
50 libelf = ../libelf/libelf.so 40 i386_SRCS = i386_init.c i386_symbol.c i386_corenote.c i386_cfi.c \
51 libdw = ../libdw/libdw.so 41 i386_retval.c i386_regs.c i386_auxv.c i386_syscall.c \
42@@ -102,7 +104,8 @@ libebl_backends_a_SOURCES = $(i386_SRCS) $(sh_SRCS) $(x86_64_SRCS) \
43 $(ia64_SRCS) $(alpha_SRCS) $(arm_SRCS) \
44 $(aarch64_SRCS) $(sparc_SRCS) $(ppc_SRCS) \
45 $(ppc64_SRCS) $(s390_SRCS) $(tilegx_SRCS) \
46- $(m68k_SRCS) $(bpf_SRCS) $(riscv_SRCS) $(csky_SRCS)
47+ $(m68k_SRCS) $(bpf_SRCS) $(riscv_SRCS) $(csky_SRCS) \
48+ $(parisc_SRCS)
49
50 libebl_backends_pic_a_SOURCES =
51 am_libebl_backends_pic_a_OBJECTS = $(libebl_backends_a_SOURCES:.c=.os)
52diff --git a/backends/libebl_parisc.h b/backends/libebl_parisc.h 52diff --git a/backends/libebl_parisc.h b/backends/libebl_parisc.h
53new file mode 100644 53new file mode 100644
54index 0000000..f473b79 54index 0000000..f473b79
@@ -826,6 +826,3 @@ index 01648bd..218ceb2 100644
826 #define R_PARISC_SEGREL64 112 /* 64 bits segment rel. address. */ 826 #define R_PARISC_SEGREL64 112 /* 64 bits segment rel. address. */
827 #define R_PARISC_PLTOFF14WR 115 /* PLT-rel. address, right 14 bits. */ 827 #define R_PARISC_PLTOFF14WR 115 /* PLT-rel. address, right 14 bits. */
828 #define R_PARISC_PLTOFF14DR 116 /* PLT-rel. address, right 14 bits. */ 828 #define R_PARISC_PLTOFF14DR 116 /* PLT-rel. address, right 14 bits. */
829--
8302.7.4
831