summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.176.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.176.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.176.bb27
1 files changed, 26 insertions, 1 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.176.bb b/meta/recipes-devtools/elfutils/elfutils_0.176.bb
index cd824e2901..031c00fb28 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.176.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.176.bb
@@ -27,16 +27,24 @@ SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
27 file://debian/hurd_path.patch \ 27 file://debian/hurd_path.patch \
28 file://debian/ignore_strmerge.diff \ 28 file://debian/ignore_strmerge.diff \
29 file://debian/disable_werror.patch \ 29 file://debian/disable_werror.patch \
30 file://debian/testsuite-ignore-elflint.diff \
31 file://0001-skip-the-test-when-gcc-not-deployed.patch \
32 file://run-ptest \
33 file://serial-tests.patch \
30 " 34 "
31SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch" 35SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch"
32 36
33SRC_URI[md5sum] = "077e4f49320cad82bf17a997068b1db9" 37SRC_URI[md5sum] = "077e4f49320cad82bf17a997068b1db9"
34SRC_URI[sha256sum] = "eb5747c371b0af0f71e86215a5ebb88728533c3a104a43d4231963f308cd1023" 38SRC_URI[sha256sum] = "eb5747c371b0af0f71e86215a5ebb88728533c3a104a43d4231963f308cd1023"
35 39
36inherit autotools gettext 40inherit autotools gettext ptest
37 41
38EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 42EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
39EXTRA_OECONF_append_class-native = " --without-bzlib" 43EXTRA_OECONF_append_class-native = " --without-bzlib"
44# gcc has been added to blacklist, we will find workaround solution
45RDEPENDS_${PN}-ptest = "libasm libelf bash"
46
47EXTRA_OECONF_append_class-target += "--enable-tests-rpath"
40 48
41do_install_append() { 49do_install_append() {
42 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then 50 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
@@ -44,6 +52,23 @@ do_install_append() {
44 fi 52 fi
45} 53}
46 54
55do_compile_ptest() {
56 cd ${B}/tests
57 oe_runmake buildtest-TESTS
58}
59
60do_install_ptest() {
61 if [ ${PTEST_ENABLED} = "1" ]; then
62 cp -r ${S}/tests/ ${D}${PTEST_PATH}
63 cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests
64 cp -r ${B}/src ${D}${PTEST_PATH}
65 cp -r ${B}/config.h ${D}${PTEST_PATH}
66 cp -r ${B}/backends ${D}${PTEST_PATH}
67 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile
68 find ${D}${PTEST_PATH} -type f -name *.[hoc] | xargs -i rm {}
69 fi
70}
71
47EXTRA_OEMAKE_class-native = "" 72EXTRA_OEMAKE_class-native = ""
48EXTRA_OEMAKE_class-nativesdk = "" 73EXTRA_OEMAKE_class-nativesdk = ""
49 74