diff options
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.170.bb')
-rw-r--r-- | meta/recipes-devtools/elfutils/elfutils_0.170.bb | 78 |
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.170.bb b/meta/recipes-devtools/elfutils/elfutils_0.170.bb new file mode 100644 index 0000000000..8a339e48c9 --- /dev/null +++ b/meta/recipes-devtools/elfutils/elfutils_0.170.bb | |||
@@ -0,0 +1,78 @@ | |||
1 | SUMMARY = "Utilities and libraries for handling compiled object files" | ||
2 | HOMEPAGE = "https://sourceware.org/elfutils" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "(GPLv3 & Elfutils-Exception)" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | DEPENDS = "libtool bzip2 zlib virtual/libintl" | ||
7 | DEPENDS_append_libc-musl = " argp-standalone fts " | ||
8 | SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2" | ||
9 | SRC_URI[md5sum] = "03599aee98c9b726c7a732a2dd0245d5" | ||
10 | SRC_URI[sha256sum] = "1f844775576b79bdc9f9c717a50058d08620323c1e935458223a12f249c9e066" | ||
11 | |||
12 | SRC_URI += "\ | ||
13 | file://0001-dso-link-change.patch \ | ||
14 | file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \ | ||
15 | file://0003-fixheadercheck.patch \ | ||
16 | file://0004-Disable-the-test-to-convert-euc-jp.patch \ | ||
17 | file://0005-fix-a-stack-usage-warning.patch \ | ||
18 | file://0006-Fix-build-on-aarch64-musl.patch \ | ||
19 | file://0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch \ | ||
20 | " | ||
21 | SRC_URI_append_libc-musl = " file://0008-build-Provide-alternatives-for-glibc-assumptions-hel.patch" | ||
22 | |||
23 | # Pick patches from debian | ||
24 | # http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.168-0.2.debian.tar.xz | ||
25 | SRC_URI += "\ | ||
26 | file://debian/hppa_backend.diff \ | ||
27 | file://debian/arm_backend.diff \ | ||
28 | file://debian/mips_backend.patch \ | ||
29 | file://debian/mips_readelf_w.patch \ | ||
30 | file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \ | ||
31 | file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \ | ||
32 | file://debian/0003-Add-mips-n64-relocation-format-hack.patch \ | ||
33 | " | ||
34 | # Fix the patches from Debian with GCC7 | ||
35 | SRC_URI += "file://debian/fallthrough.patch" | ||
36 | |||
37 | # The buildsystem wants to generate 2 .h files from source using a binary it just built, | ||
38 | # which can not pass the cross compiling, so let's work around it by adding 2 .h files | ||
39 | # along with the do_configure_prepend() | ||
40 | |||
41 | inherit autotools gettext | ||
42 | |||
43 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" | ||
44 | EXTRA_OECONF_append_class-native = " --without-bzlib" | ||
45 | |||
46 | do_install_append() { | ||
47 | if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then | ||
48 | rm -f ${D}${bindir}/eu-objdump | ||
49 | fi | ||
50 | } | ||
51 | |||
52 | EXTRA_OEMAKE_class-native = "" | ||
53 | EXTRA_OEMAKE_class-nativesdk = "" | ||
54 | |||
55 | ALLOW_EMPTY_${PN}_libc-musl = "1" | ||
56 | |||
57 | BBCLASSEXTEND = "native nativesdk" | ||
58 | |||
59 | # Package utilities separately | ||
60 | PACKAGES =+ "${PN}-binutils libelf libasm libdw" | ||
61 | FILES_${PN}-binutils = "\ | ||
62 | ${bindir}/eu-addr2line \ | ||
63 | ${bindir}/eu-ld \ | ||
64 | ${bindir}/eu-nm \ | ||
65 | ${bindir}/eu-readelf \ | ||
66 | ${bindir}/eu-size \ | ||
67 | ${bindir}/eu-strip" | ||
68 | |||
69 | FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" | ||
70 | FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" | ||
71 | FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" | ||
72 | # Some packages have the version preceeding the .so instead properly | ||
73 | # versioned .so.<version>, so we need to reorder and repackage. | ||
74 | #FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" | ||
75 | #FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" | ||
76 | |||
77 | # The package contains symlinks that trip up insane | ||
78 | INSANE_SKIP_${MLPREFIX}libdw = "dev-so" | ||