summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.164.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.164.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.164.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.164.bb b/meta/recipes-devtools/elfutils/elfutils_0.164.bb
new file mode 100644
index 0000000000..c27635dda3
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils_0.164.bb
@@ -0,0 +1,86 @@
1SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://fedorahosted.org/elfutils"
3SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7
8SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/${BP}.tar.bz2"
9
10SRC_URI[md5sum] = "2e4536c1c48034f188a80789a59114d8"
11SRC_URI[sha256sum] = "9683c025928a12d06b7fe812928aa6235249e22d197d086f7084606a48165900"
12
13SRC_URI += "\
14 file://mempcpy.patch \
15 file://dso-link-change.patch \
16 file://Fix_elf_cvt_gunhash.patch \
17 file://fixheadercheck.patch \
18 file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \
19 file://0001-remove-the-unneed-checking.patch \
20 file://0001-fix-a-stack-usage-warning.patch \
21"
22
23# pick the patch from debian
24# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.164-1.debian.tar.xz
25SRC_URI += "\
26 file://hppa_backend.diff \
27 file://arm_backend.diff \
28 file://mips_backend.diff \
29 file://m68k_backend.diff \
30 file://testsuite-ignore-elflint.diff \
31 file://mips_readelf_w.patch \
32 file://kfreebsd_path.patch \
33 file://0001-Ignore-differences-between-mips-machine-identifiers.patch \
34 file://0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
35 file://0003-Add-mips-n64-relocation-format-hack.patch \
36"
37
38# Only apply when building uclibc based target recipe
39SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.161.patch"
40
41# The buildsystem wants to generate 2 .h files from source using a binary it just built,
42# which can not pass the cross compiling, so let's work around it by adding 2 .h files
43# along with the do_configure_prepend()
44
45inherit autotools gettext
46
47EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
48EXTRA_OECONF_append_class-native = " --without-bzlib"
49EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
50
51do_install_append() {
52 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
53 rm ${D}${bindir}/eu-objdump
54 fi
55}
56
57# we can not build complete elfutils when using uclibc
58# but some recipes e.g. gcc 4.5 depends on libelf so we
59# build only libelf for uclibc case
60
61EXTRA_OEMAKE_libc-uclibc = "-C libelf"
62EXTRA_OEMAKE_class-native = ""
63EXTRA_OEMAKE_class-nativesdk = ""
64
65BBCLASSEXTEND = "native nativesdk"
66
67# Package utilities separately
68PACKAGES =+ "${PN}-binutils libelf libasm libdw"
69FILES_${PN}-binutils = "\
70 ${bindir}/eu-addr2line \
71 ${bindir}/eu-ld \
72 ${bindir}/eu-nm \
73 ${bindir}/eu-readelf \
74 ${bindir}/eu-size \
75 ${bindir}/eu-strip"
76
77FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
78FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
79FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
80# Some packages have the version preceeding the .so instead properly
81# versioned .so.<version>, so we need to reorder and repackage.
82#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
83#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
84
85# The package contains symlinks that trip up insane
86INSANE_SKIP_${MLPREFIX}libdw = "dev-so"