summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.163.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.163.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.163.bb10
1 files changed, 0 insertions, 10 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.163.bb b/meta/recipes-devtools/elfutils/elfutils_0.163.bb
index b34bfdd4b9..c4fdabdb31 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.163.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.163.bb
@@ -42,22 +42,12 @@ SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.161.patch"
42# which can not pass the cross compiling, so let's work around it by adding 2 .h files 42# which can not pass the cross compiling, so let's work around it by adding 2 .h files
43# along with the do_configure_prepend() 43# along with the do_configure_prepend()
44 44
45SRC_URI += "\
46 file://i386_dis.h \
47 file://x86_64_dis.h \
48"
49inherit autotools gettext 45inherit autotools gettext
50 46
51EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 47EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
52EXTRA_OECONF_append_class-native = " --without-bzlib" 48EXTRA_OECONF_append_class-native = " --without-bzlib"
53EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc" 49EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
54 50
55do_configure_prepend() {
56 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
57
58 cp ${WORKDIR}/*dis.h ${S}/libcpu
59}
60
61do_install_append() { 51do_install_append() {
62 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then 52 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
63 rm ${D}${bindir}/eu-objdump 53 rm ${D}${bindir}/eu-objdump