diff options
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.161.bb')
-rw-r--r-- | meta/recipes-devtools/elfutils/elfutils_0.161.bb | 97 |
1 files changed, 97 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.161.bb b/meta/recipes-devtools/elfutils/elfutils_0.161.bb new file mode 100644 index 0000000000..a3c1f36f6a --- /dev/null +++ b/meta/recipes-devtools/elfutils/elfutils_0.161.bb | |||
@@ -0,0 +1,97 @@ | |||
1 | SUMMARY = "Utilities and libraries for handling compiled object files" | ||
2 | HOMEPAGE = "https://fedorahosted.org/elfutils" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "(GPLv3 & Elfutils-Exception)" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | DEPENDS = "libtool bzip2 zlib virtual/libintl" | ||
7 | |||
8 | SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/elfutils-${PV}.tar.bz2" | ||
9 | |||
10 | SRC_URI[md5sum] = "e1b9847c9a6a1ad340de8d47a863ec52" | ||
11 | SRC_URI[sha256sum] = "570c91a1783fa5386aaa2dfdd08dda1de777c2b63bf3b9c1437d635ffdd7a070" | ||
12 | |||
13 | SRC_URI += "\ | ||
14 | file://mempcpy.patch \ | ||
15 | file://dso-link-change.patch \ | ||
16 | file://Fix_elf_cvt_gunhash.patch \ | ||
17 | file://fixheadercheck.patch \ | ||
18 | " | ||
19 | |||
20 | # pick the patch from debian | ||
21 | # http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.159-4.debian.tar.xz | ||
22 | SRC_URI += "\ | ||
23 | file://redhat-portability.diff \ | ||
24 | file://hppa_backend.diff \ | ||
25 | file://arm_backend.diff \ | ||
26 | file://mips_backend.diff \ | ||
27 | file://m68k_backend.diff \ | ||
28 | file://testsuite-ignore-elflint.diff \ | ||
29 | file://scanf-format.patch \ | ||
30 | file://mips_readelf_w.patch \ | ||
31 | file://arm_func_value.patch \ | ||
32 | file://arm_unwind_ret_mask.patch \ | ||
33 | file://non_linux.patch \ | ||
34 | " | ||
35 | |||
36 | # Only apply when building uclibc based target recipe | ||
37 | SRC_URI_append_libc-uclibc = " file://uclibc-support.patch" | ||
38 | |||
39 | # The buildsystem wants to generate 2 .h files from source using a binary it just built, | ||
40 | # which can not pass the cross compiling, so let's work around it by adding 2 .h files | ||
41 | # along with the do_configure_prepend() | ||
42 | |||
43 | SRC_URI += "\ | ||
44 | file://i386_dis.h \ | ||
45 | file://x86_64_dis.h \ | ||
46 | " | ||
47 | inherit autotools gettext | ||
48 | |||
49 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" | ||
50 | EXTRA_OECONF_append_class-native = " --without-bzlib" | ||
51 | EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc" | ||
52 | |||
53 | do_configure_prepend() { | ||
54 | sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am | ||
55 | |||
56 | cp ${WORKDIR}/*dis.h ${S}/libcpu | ||
57 | } | ||
58 | |||
59 | do_install_append() { | ||
60 | if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then | ||
61 | rm ${D}${bindir}/eu-objdump | ||
62 | fi | ||
63 | } | ||
64 | |||
65 | # we can not build complete elfutils when using uclibc | ||
66 | # but some recipes e.g. gcc 4.5 depends on libelf so we | ||
67 | # build only libelf for uclibc case | ||
68 | |||
69 | EXTRA_OEMAKE_libc-uclibc = "-C libelf" | ||
70 | EXTRA_OEMAKE_class-native = "" | ||
71 | EXTRA_OEMAKE_class-nativesdk = "" | ||
72 | |||
73 | BBCLASSEXTEND = "native nativesdk" | ||
74 | |||
75 | # Package utilities separately | ||
76 | PACKAGES =+ "${PN}-binutils libelf libasm libdw libdw-dev libasm-dev libelf-dev" | ||
77 | FILES_${PN}-binutils = "\ | ||
78 | ${bindir}/eu-addr2line \ | ||
79 | ${bindir}/eu-ld \ | ||
80 | ${bindir}/eu-nm \ | ||
81 | ${bindir}/eu-readelf \ | ||
82 | ${bindir}/eu-size \ | ||
83 | ${bindir}/eu-strip" | ||
84 | |||
85 | FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" | ||
86 | FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" | ||
87 | FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" | ||
88 | FILES_libelf-dev = "${libdir}/libelf.so ${includedir}" | ||
89 | FILES_libasm-dev = "${libdir}/libasm.so ${includedir}/elfutils/libasm.h" | ||
90 | FILES_libdw-dev = "${libdir}/libdw.so ${includedir}/dwarf.h ${includedir}/elfutils/libdw*.h" | ||
91 | # Some packages have the version preceeding the .so instead properly | ||
92 | # versioned .so.<version>, so we need to reorder and repackage. | ||
93 | #FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" | ||
94 | #FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" | ||
95 | |||
96 | # The package contains symlinks that trip up insane | ||
97 | INSANE_SKIP_${MLPREFIX}libdw = "dev-so" | ||