summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.148.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.148.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.148.bb b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
new file mode 100644
index 0000000000..18887e4b96
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -0,0 +1,63 @@
1DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects."
2HOMEPAGE = "https://fedorahosted.org/elfutils"
3SECTION = "base"
4LICENSE = "GPLv2 with exceptions"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3\
6 file://EXCEPTION;md5=570adcb0c1218ab57f2249c67d0ce417"
7DEPENDS = "libtool"
8
9PR = "r1"
10
11SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/elfutils-${PV}.tar.bz2"
12
13# pick the patch from debian
14# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.148-1.debian.tar.gz
15
16SRC_URI += "\
17 file://redhat-portability.diff \
18 file://redhat-robustify.diff \
19 file://hppa_backend.diff \
20 file://arm_backend.diff \
21 file://mips_backend.diff \
22 file://m68k_backend.diff \
23 file://do-autoreconf.diff \
24 file://testsuite-ignore-elflint.diff \
25 file://elf_additions.diff \
26 file://elfutils-fsize.patch \
27"
28
29# The buildsystem wants to generate 2 .h files from source using a binary it just built,
30# which can not pass the cross compiling, so let's work around it by adding 2 .h files
31# along with the do_configure_prepend()
32
33SRC_URI += "\
34 file://i386_dis.h \
35 file://x86_64_dis.h \
36"
37
38inherit autotools
39
40EXTRA_OECONF = "--program-prefix=eu-"
41
42do_configure_prepend() {
43 sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
44
45 cp ${WORKDIR}/*dis.h ${S}/libcpu
46}
47
48BBCLASSEXTEND = "native nativesdk"
49
50# Package utilities separately
51PACKAGES =+ "${PN}-binutils"
52FILES_${PN}-binutils = "\
53 ${bindir}/eu-addr2line \
54 ${bindir}/eu-ld \
55 ${bindir}/eu-nm \
56 ${bindir}/eu-readelf \
57 ${bindir}/eu-size \
58 ${bindir}/eu-strip"
59# Fix library issues
60FILES_${PN} =+ "${libdir}/*-${PV}.so"
61
62# The elfutils package contains symlinks that trip up insane
63INSANE_SKIP_elfutils = "1"