summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dpkg/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/dpkg/run-postinsts_1.0.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb b/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
deleted file mode 100644
index 4c9b2fd75a..0000000000
--- a/meta/recipes-devtools/dpkg/run-postinsts_1.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "Run postinstall scripts on device using awk"
2SECTION = "devel"
3PR = "r9"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SRC_URI = "file://run-postinsts file://run-postinsts.awk"
9
10INITSCRIPT_NAME = "run-postinsts"
11INITSCRIPT_PARAMS = "start 98 S ."
12
13inherit update-rc.d
14
15do_configure() {
16 :
17}
18
19do_compile () {
20 :
21}
22
23do_install() {
24 install -d ${D}${sysconfdir}/init.d/
25 install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
26
27 install -d ${D}${datadir}/${BPN}/
28 install -m 0644 ${WORKDIR}/run-postinsts.awk ${D}${datadir}/${BPN}/
29}