diff options
Diffstat (limited to 'meta/recipes-devtools/docbook-xml/docbook-xsl-stylesheets_1.78.1.bb')
-rw-r--r-- | meta/recipes-devtools/docbook-xml/docbook-xsl-stylesheets_1.78.1.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-devtools/docbook-xml/docbook-xsl-stylesheets_1.78.1.bb b/meta/recipes-devtools/docbook-xml/docbook-xsl-stylesheets_1.78.1.bb new file mode 100644 index 0000000000..39528c89c4 --- /dev/null +++ b/meta/recipes-devtools/docbook-xml/docbook-xsl-stylesheets_1.78.1.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "XSL stylesheets for processing DocBook XML to various output formats" | ||
2 | HOMEPAGE = "http://docbook.sourceforge.net" | ||
3 | LICENSE = "XSL" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6eeeed43d498c22a835382533356462" | ||
5 | |||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/docbook/docbook-xsl-${PV}.tar.bz2 \ | ||
7 | file://docbook-xsl.xml \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "6dd0f89131cc35bf4f2ed105a1c17771" | ||
11 | SRC_URI[sha256sum] = "c98f7296ab5c8ccd2e0bc07634976a37f50847df2d8a59bdb1e157664700b467" | ||
12 | |||
13 | S = "${WORKDIR}/docbook-xsl-${PV}" | ||
14 | |||
15 | inherit allarch | ||
16 | BBCLASSEXTEND = "native" | ||
17 | |||
18 | SSTATEPOSTINSTFUNCS_append_class-native = " docbook_xsl_stylesheets_sstate_postinst" | ||
19 | SYSROOT_PREPROCESS_FUNCS_append_class-native = " docbook_xsl_stylesheets_sysroot_preprocess" | ||
20 | |||
21 | do_configre (){ | ||
22 | : | ||
23 | } | ||
24 | |||
25 | do_compile (){ | ||
26 | : | ||
27 | } | ||
28 | |||
29 | do_install () { | ||
30 | # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/docbook-xsl.html | ||
31 | # for details. | ||
32 | install -v -m755 -d ${D}${datadir}/xml/docbook/xsl-stylesheets-1.78.1 | ||
33 | |||
34 | cp -v -R VERSION common eclipse epub extensions fo highlighting html \ | ||
35 | htmlhelp images javahelp lib manpages params profiling \ | ||
36 | roundtrip slides template tests tools webhelp website \ | ||
37 | xhtml xhtml-1_1 catalog.xml \ | ||
38 | ${D}${datadir}/xml/docbook/xsl-stylesheets-1.78.1 | ||
39 | |||
40 | ln -s VERSION ${D}/${datadir}/xml/docbook/xsl-stylesheets-1.78.1/VERSION.xsl | ||
41 | |||
42 | install -v -m644 -D README \ | ||
43 | ${D}${datadir}/doc/docbook-xsl-1.78.1/README.txt | ||
44 | install -v -m644 RELEASE-NOTES* NEWS* \ | ||
45 | ${D}${datadir}/doc/docbook-xsl-1.78.1 | ||
46 | |||
47 | install -d ${D}${sysconfdir}/xml/ | ||
48 | install -m 755 ${WORKDIR}/docbook-xsl.xml ${D}${sysconfdir}/xml/docbook-xsl.xml | ||
49 | |||
50 | } | ||
51 | |||
52 | docbook_xsl_stylesheets_sstate_postinst () { | ||
53 | if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ] | ||
54 | then | ||
55 | # Ensure that the catalog file sgml-docbook.cat is properly | ||
56 | # updated when the package is installed from sstate cache. | ||
57 | sed -i -e "s|file://.*/usr/share/xml|file://${datadir}/xml|g" ${SYSROOT_DESTDIR}${sysconfdir}/xml/docbook-xsl.xml | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | docbook_xsl_stylesheets_sysroot_preprocess () { | ||
62 | # Update the hardcode dir in docbook-xml.xml | ||
63 | sed -i -e "s|file:///usr/share/xml|file://${datadir}/xml|g" ${SYSROOT_DESTDIR}${sysconfdir}/xml/docbook-xsl.xml | ||
64 | } | ||
65 | |||
66 | FILES_${PN} = "${datadir}/xml/* ${sysconfdir}/xml/docbook-xsl.xml" | ||
67 | FILES_${PN}-doc = "${datadir}/doc/*" | ||