summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb')
-rw-r--r--meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
new file mode 100644
index 0000000000..c3a5f3b421
--- /dev/null
+++ b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Utilities for formatting and manipulating DocBook documents"
2DESCRIPTION = "A collection of all the free software tools you need to \
3work on and format DocBook documents."
4HOMEPAGE = "http://sources.redhat.com/docbook-tools/"
5SECTION = "console/utils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8DEPENDS = "openjade-native sgmlspl-native docbook-dsssl-stylesheets-native docbook-sgml-dtd-3.1-native"
9
10PR = "r3"
11
12SRC_URI = "\
13 ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/docbook-utils-${PV}.tar.gz \
14 file://re.patch \
15"
16
17SRC_URI[md5sum] = "6b41b18c365c01f225bc417cf632d81c"
18SRC_URI[sha256sum] = "48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9"
19
20inherit autotools native
21
22do_configure_prepend() {
23 # Fix hard-coded references to /etc/sgml
24 if [ ! -e ${S}/.sed_done ]; then
25 sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" ${S}/bin/jw.in
26 sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" ${S}/doc/man/Makefile.am
27 sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" ${S}/doc/HTML/Makefile.am
28
29 # Point jw to the native sysroot catalog
30 sed -i -e 's|^SGML_EXTRA_CATALOGS=""|SGML_EXTRA_CATALOGS=":${sysconfdir}/sgml/catalog"|g' ${S}/bin/jw.in
31 touch ${S}/.sed_done
32 fi
33}
34do_unpack[cleandirs] += "${S}"
35
36do_install() {
37 install -d ${D}${bindir}
38 # Install the binaries and a bunch of other commonly used names for them.
39 for doctype in html ps dvi man pdf rtf tex texi txt
40 do
41 install -m 0755 ${S}/bin/docbook2$doctype ${D}${bindir}/
42 ln -sf docbook2x-$doctype ${D}${bindir}/db2$doctype
43 ln -sf docbook2$doctype ${D}${bindir}/db2$doctype
44 ln -sf docbook2$doctype ${D}${bindir}/docbook-to-$doctype
45 done
46
47 install -m 0755 ${B}/bin/jw ${D}${bindir}/
48 for i in backends/dvi backends/html \
49 backends/pdf backends/ps backends/rtf backends/tex \
50 backends/txt \
51 helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
52 docbook-utils.dsl
53 do
54 install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
55 install ${S}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
56 done
57 for i in backends/man backends/texi frontends/docbook
58 do
59 install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
60 install ${B}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
61 done
62
63}