diff options
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_git.bb')
-rw-r--r-- | meta/recipes-devtools/dnf/dnf_git.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_git.bb b/meta/recipes-devtools/dnf/dnf_git.bb new file mode 100644 index 0000000000..ff22d6f5f0 --- /dev/null +++ b/meta/recipes-devtools/dnf/dnf_git.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
4 | file://PACKAGE-LICENSING;md5=bfc29916e11321be06924c4fb096fdcc \ | ||
5 | " | ||
6 | |||
7 | SRC_URI = "git://github.com/rpm-software-management/dnf.git \ | ||
8 | file://0028-Use-backports.lzma-not-lzma.patch \ | ||
9 | file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
10 | file://0030-Run-python-scripts-using-env.patch \ | ||
11 | file://0001-Do-not-prepend-installroot-to-logdir.patch \ | ||
12 | file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \ | ||
13 | file://0001-Corretly-install-tmpfiles.d-configuration.patch \ | ||
14 | " | ||
15 | |||
16 | PV = "2.0.0+git${SRCPV}" | ||
17 | SRCREV = "f0093d672d3069cfee8447973ae70ef615fd8886" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | inherit cmake gettext bash-completion distutils-base systemd | ||
22 | |||
23 | DEPENDS += "libdnf librepo libcomps python-pygpgme python-iniparse" | ||
24 | # python 2.x only, drop when moving to python 3.x | ||
25 | DEPENDS += "python-backports-lzma" | ||
26 | |||
27 | # manpages generation requires http://www.sphinx-doc.org/ | ||
28 | EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}" | ||
29 | |||
30 | BBCLASSEXTEND = "native nativesdk" | ||
31 | |||
32 | RDEPENDS_${PN}_class-target += "python-core python-codecs python-netclient python-email python-threading python-distutils librepo python-shell python-subprocess libcomps libdnf python-sqlite3 python-compression python-pygpgme python-backports-lzma python-rpm python-iniparse python-json python-importlib python-curses python-argparse" | ||
33 | |||
34 | # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in | ||
35 | do_install_append_class-native() { | ||
36 | create_wrapper ${D}/${bindir}/dnf-2 \ | ||
37 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
38 | RPM_NO_CHROOT_FOR_SCRIPTS=1 | ||
39 | } | ||
40 | |||
41 | SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \ | ||
42 | dnf-automatic-download.service dnf-automatic-download.timer \ | ||
43 | dnf-automatic-install.service dnf-automatic-install.timer \ | ||
44 | dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \ | ||
45 | " | ||