summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_git.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_git.bb b/meta/recipes-devtools/dnf/dnf_git.bb
index 018352a6c9..3a2cb635e4 100644
--- a/meta/recipes-devtools/dnf/dnf_git.bb
+++ b/meta/recipes-devtools/dnf/dnf_git.bb
@@ -30,9 +30,17 @@ EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
30BBCLASSEXTEND = "native nativesdk" 30BBCLASSEXTEND = "native nativesdk"
31RDEPENDS_${PN}_class-target += "python-core python-codecs python-netclient python-email python-threading python-distutils librepo python-shell python-subprocess libcomps libdnf python-sqlite3 python-compression python-pygpgme python-backports-lzma python-rpm python-iniparse python-json python-importlib python-curses python-argparse" 31RDEPENDS_${PN}_class-target += "python-core python-codecs python-netclient python-email python-threading python-distutils librepo python-shell python-subprocess libcomps libdnf python-sqlite3 python-compression python-pygpgme python-backports-lzma python-rpm python-iniparse python-json python-importlib python-curses python-argparse"
32 32
33# Create a symlink called 'dnf' as 'make install' does not do it, but
34# .spec file in dnf source tree does (and then Fedora and dnf documentation
35# says that dnf binary is plain 'dnf').
36do_install_append() {
37 ln -s -r ${D}/${bindir}/dnf-2 ${D}/${bindir}/dnf
38 ln -s -r ${D}/${bindir}/dnf-automatic-2 ${D}/${bindir}/dnf-automatic
39}
40
33# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in 41# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
34do_install_append_class-native() { 42do_install_append_class-native() {
35 create_wrapper ${D}/${bindir}/dnf-2 \ 43 create_wrapper ${D}/${bindir}/dnf \
36 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ 44 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
37 RPM_NO_CHROOT_FOR_SCRIPTS=1 45 RPM_NO_CHROOT_FOR_SCRIPTS=1
38} 46}