diff options
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_4.2.21.bb')
-rw-r--r-- | meta/recipes-devtools/dnf/dnf_4.2.21.bb | 89 |
1 files changed, 89 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.2.21.bb b/meta/recipes-devtools/dnf/dnf_4.2.21.bb new file mode 100644 index 0000000000..8f7757b72f --- /dev/null +++ b/meta/recipes-devtools/dnf/dnf_4.2.21.bb | |||
@@ -0,0 +1,89 @@ | |||
1 | SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver" | ||
2 | DESCRIPTION = "Software package manager that installs, updates, and removes \ | ||
3 | packages on RPM-based Linux distributions. It automatically computes \ | ||
4 | dependencies and determines the actions required to install packages." | ||
5 | LICENSE = "GPLv2" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
7 | file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \ | ||
8 | " | ||
9 | |||
10 | SRC_URI = "git://github.com/rpm-software-management/dnf.git \ | ||
11 | file://0001-Corretly-install-tmpfiles.d-configuration.patch \ | ||
12 | file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \ | ||
13 | file://0005-Do-not-prepend-installroot-to-logdir.patch \ | ||
14 | file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
15 | file://0030-Run-python-scripts-using-env.patch \ | ||
16 | file://0001-set-python-path-for-completion_helper.patch \ | ||
17 | " | ||
18 | |||
19 | SRCREV = "864c381baabf024c299dca75abfda96139b8f583" | ||
20 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | inherit cmake gettext bash-completion distutils3-base systemd | ||
25 | |||
26 | DEPENDS += "libdnf librepo libcomps python3-iniparse" | ||
27 | |||
28 | # manpages generation requires http://www.sphinx-doc.org/ | ||
29 | EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" | ||
30 | |||
31 | BBCLASSEXTEND = "native nativesdk" | ||
32 | |||
33 | RDEPENDS_${PN} += " \ | ||
34 | python3-core \ | ||
35 | python3-codecs \ | ||
36 | python3-netclient \ | ||
37 | python3-email \ | ||
38 | python3-threading \ | ||
39 | python3-distutils \ | ||
40 | python3-logging \ | ||
41 | python3-fcntl \ | ||
42 | librepo \ | ||
43 | python3-shell \ | ||
44 | libcomps \ | ||
45 | libdnf \ | ||
46 | python3-sqlite3 \ | ||
47 | python3-compression \ | ||
48 | python3-rpm \ | ||
49 | python3-iniparse \ | ||
50 | python3-json \ | ||
51 | python3-curses \ | ||
52 | python3-misc \ | ||
53 | python3-gpg \ | ||
54 | " | ||
55 | |||
56 | RDEPENDS_${PN}_class-native = "" | ||
57 | |||
58 | RRECOMMENDS_${PN}_class-target += "gnupg" | ||
59 | |||
60 | # Create a symlink called 'dnf' as 'make install' does not do it, but | ||
61 | # .spec file in dnf source tree does (and then Fedora and dnf documentation | ||
62 | # says that dnf binary is plain 'dnf'). | ||
63 | do_install_append() { | ||
64 | lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf | ||
65 | lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic | ||
66 | } | ||
67 | |||
68 | # Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in | ||
69 | do_install_append_class-native() { | ||
70 | create_wrapper ${D}/${bindir}/dnf \ | ||
71 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ | ||
72 | RPM_NO_CHROOT_FOR_SCRIPTS=1 | ||
73 | } | ||
74 | |||
75 | do_install_append_class-nativesdk() { | ||
76 | create_wrapper ${D}/${bindir}/dnf \ | ||
77 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \ | ||
78 | RPM_NO_CHROOT_FOR_SCRIPTS=1 | ||
79 | } | ||
80 | |||
81 | SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \ | ||
82 | dnf-automatic.service dnf-automatic.timer \ | ||
83 | dnf-automatic-download.service dnf-automatic-download.timer \ | ||
84 | dnf-automatic-install.service dnf-automatic-install.timer \ | ||
85 | dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \ | ||
86 | " | ||
87 | SYSTEMD_AUTO_ENABLE ?= "disable" | ||
88 | |||
89 | PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}" | ||