summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_2.7.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_2.7.5.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_2.7.5.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_2.7.5.bb b/meta/recipes-devtools/dnf/dnf_2.7.5.bb
new file mode 100644
index 0000000000..fbd3bd4571
--- /dev/null
+++ b/meta/recipes-devtools/dnf/dnf_2.7.5.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://PACKAGE-LICENSING;md5=bfc29916e11321be06924c4fb096fdcc \
5 "
6
7SRC_URI = "git://github.com/rpm-software-management/dnf.git \
8 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
9 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
10 file://0005-Do-not-prepend-installroot-to-logdir.patch \
11 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
12 file://0030-Run-python-scripts-using-env.patch \
13 "
14
15SRCREV = "564c44667c7014843fa6f1732621093114ec59b2"
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
17
18S = "${WORKDIR}/git"
19
20inherit cmake gettext bash-completion distutils3-base systemd
21
22DEPENDS += "libdnf librepo libcomps python3-iniparse"
23
24# manpages generation requires http://www.sphinx-doc.org/
25EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
26
27BBCLASSEXTEND = "native nativesdk"
28RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc python3-gpg"
29# Recommend gnupg so that GPG signature check on repository metadata is possible
30RRECOMMENDS_${PN}_class-target += "gnupg"
31
32# Create a symlink called 'dnf' as 'make install' does not do it, but
33# .spec file in dnf source tree does (and then Fedora and dnf documentation
34# says that dnf binary is plain 'dnf').
35do_install_append() {
36 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
37 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
38}
39
40# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
41do_install_append_class-native() {
42 create_wrapper ${D}/${bindir}/dnf \
43 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
44 RPM_NO_CHROOT_FOR_SCRIPTS=1
45}
46
47SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
48 dnf-automatic.service dnf-automatic.timer \
49 dnf-automatic-download.service dnf-automatic-download.timer \
50 dnf-automatic-install.service dnf-automatic-install.timer \
51 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
52"