summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/devel-config/nfs-export-root.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/devel-config/nfs-export-root.bb')
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/devel-config/nfs-export-root.bb b/meta/recipes-devtools/devel-config/nfs-export-root.bb
new file mode 100644
index 0000000000..5fa8cb3c0f
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/nfs-export-root.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Enables NFS access from any host to the entire filesystem (for development purposes)"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
4 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6PR = "r1"
7
8SRC_URI = "file://exports"
9
10S = "${WORKDIR}"
11
12do_install() {
13 install -d ${D}${sysconfdir}
14 install -m 0644 exports ${D}${sysconfdir}/
15}
16
17RDEPENDS_${PN} = "packagegroup-core-nfs-server"