summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/devel-config/nfs-export-root.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/devel-config/nfs-export-root.bb')
-rw-r--r--meta/recipes-devtools/devel-config/nfs-export-root.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/devel-config/nfs-export-root.bb b/meta/recipes-devtools/devel-config/nfs-export-root.bb
new file mode 100644
index 0000000000..169d00581d
--- /dev/null
+++ b/meta/recipes-devtools/devel-config/nfs-export-root.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Configuration script to export target rootfs filesystem"
2DESCRIPTION = "Enables NFS access from any host to the entire filesystem (for development purposes)."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7PR = "r1"
8
9SRC_URI = "file://exports"
10
11S = "${WORKDIR}"
12
13do_install() {
14 install -d ${D}${sysconfdir}
15 install -m 0644 exports ${D}${sysconfdir}/
16}
17
18RDEPENDS_${PN} = "packagegroup-core-nfs-server"