summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_git.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
index 31761368b7..9be9f9e51a 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
@@ -21,7 +21,7 @@ inherit cmake pkgconfig bash-completion distutils3-base
21 21
22EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" 22EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
23 23
24BBCLASSEXTEND = "native" 24BBCLASSEXTEND = "native nativesdk"
25 25
26# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in 26# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
27do_install_append_class-native() { 27do_install_append_class-native() {
@@ -29,3 +29,8 @@ do_install_append_class-native() {
29 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm 29 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
30} 30}
31 31
32do_install_append_class-nativesdk() {
33 create_wrapper ${D}/${bindir}/createrepo_c \
34 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
35 rm -rf ${D}/etc
36}