diff options
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.15.11.bb')
-rw-r--r-- | meta/recipes-devtools/createrepo-c/createrepo-c_0.15.11.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.11.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.11.bb new file mode 100644 index 0000000000..969894e448 --- /dev/null +++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.15.11.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | DESCRIPTION = "C implementation of createrepo." | ||
2 | HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
6 | |||
7 | SRC_URI = "git://github.com/rpm-software-management/createrepo_c \ | ||
8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ | ||
9 | " | ||
10 | |||
11 | SRCREV = "ea3bcf302c1a071040e1a8b6ad77861c12a2ae99" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm" | ||
16 | DEPENDS_append_class-native = " file-replacement-native" | ||
17 | |||
18 | inherit cmake pkgconfig bash-completion distutils3-base | ||
19 | |||
20 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF" | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
23 | |||
24 | # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in | ||
25 | do_install_append_class-native() { | ||
26 | create_wrapper ${D}/${bindir}/createrepo_c \ | ||
27 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm | ||
28 | } | ||
29 | |||
30 | do_install_append_class-nativesdk() { | ||
31 | create_wrapper ${D}/${bindir}/createrepo_c \ | ||
32 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm | ||
33 | rm -rf ${D}/etc | ||
34 | } | ||