diff options
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake_2.8.10.2.bb')
-rw-r--r-- | meta/recipes-devtools/cmake/cmake_2.8.10.2.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb b/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb new file mode 100644 index 0000000000..ce398ddc1b --- /dev/null +++ b/meta/recipes-devtools/cmake/cmake_2.8.10.2.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | require cmake.inc | ||
2 | |||
3 | inherit cmake | ||
4 | |||
5 | DEPENDS += "curl expat zlib libarchive ncurses" | ||
6 | |||
7 | PR = "${INC_PR}.0" | ||
8 | |||
9 | SRC_URI += "file://dont-run-cross-binaries.patch" | ||
10 | |||
11 | SRC_URI[md5sum] = "097278785da7182ec0aea8769d06860c" | ||
12 | SRC_URI[sha256sum] = "ce524fb39da06ee6d47534bbcec6e0b50422e18b62abc4781a4ba72ea2910eb1" | ||
13 | |||
14 | # Strip ${prefix} from ${docdir}, set result into docdir_stripped | ||
15 | python () { | ||
16 | prefix=d.getVar("prefix", True) | ||
17 | docdir=d.getVar("docdir", True) | ||
18 | |||
19 | if not docdir.startswith(prefix): | ||
20 | raise bb.build.FuncFailed('docdir must contain prefix as its prefix') | ||
21 | |||
22 | docdir_stripped = docdir[len(prefix):] | ||
23 | if len(docdir_stripped) > 0 and docdir_stripped[0] == '/': | ||
24 | docdir_stripped = docdir_stripped[1:] | ||
25 | |||
26 | d.setVar("docdir_stripped", docdir_stripped) | ||
27 | } | ||
28 | |||
29 | EXTRA_OECMAKE=" \ | ||
30 | -DCMAKE_DOC_DIR=${docdir_stripped}/cmake-${CMAKE_MAJOR_VERSION} \ | ||
31 | -DCMAKE_USE_SYSTEM_LIBRARIES=1 \ | ||
32 | -DKWSYS_CHAR_IS_SIGNED=1 \ | ||
33 | -DBUILD_CursesDialog=0 \ | ||
34 | ${@base_contains('DISTRO_FEATURES', 'largefile', '-DKWSYS_LFS_WORKS=1', '-DKWSYS_LFS_DISABLE=1', d)} \ | ||
35 | " | ||
36 | |||
37 | FILES_${PN} += "${datadir}/cmake-${CMAKE_MAJOR_VERSION}" | ||
38 | FILES_${PN}-doc += "${docdir}/cmake-${CMAKE_MAJOR_VERSION}" | ||
39 | |||
40 | BBCLASSEXTEND = "nativesdk" | ||