summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.7.0.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.7.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb b/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
new file mode 100644
index 0000000000..7ad4345efe
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.7.0.bb
@@ -0,0 +1,37 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
21 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
22 -DHAVE_SYS_ACL_H=0 \
23"
24
25do_configure () {
26 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
27}
28
29do_compile() {
30 oe_runmake
31}
32
33do_install() {
34 oe_runmake 'DESTDIR=${D}' install
35}
36
37do_compile[progress] = "percent"