summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.6.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.6.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.6.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.6.2.bb
new file mode 100644
index 0000000000..aec0d64de1
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.6.2.bb
@@ -0,0 +1,36 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
21 -DHAVE_SYS_ACL_H=0 \
22"
23
24do_configure () {
25 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
26}
27
28do_compile() {
29 oe_runmake
30}
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34}
35
36do_compile[progress] = "percent"