summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.2.1.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.2.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.2.1.bb b/meta/recipes-devtools/ccache/ccache_4.2.1.bb
new file mode 100644
index 0000000000..90b9c6181f
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_4.2.1.bb
@@ -0,0 +1,23 @@
1SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=698a26b57e513d678e1e7727bf56395b"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
15SRC_URI[sha256sum] = "320d2b17d2f76393e5d4bb28c8dee5ca783248e9cd23dff0654694d60f8a4b62"
16
17UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
18
19inherit cmake
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"