summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_3.7.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_3.7.9.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_3.7.9.bb28
1 files changed, 27 insertions, 1 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_3.7.9.bb b/meta/recipes-devtools/ccache/ccache_3.7.9.bb
index a4de6c9fe1..e55854bfa8 100644
--- a/meta/recipes-devtools/ccache/ccache_3.7.9.bb
+++ b/meta/recipes-devtools/ccache/ccache_3.7.9.bb
@@ -1,7 +1,33 @@
1require ccache.inc 1SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
2 8
3LICENSE = "GPLv3+" 9LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=22d514dbc01fdf9a9784334b6b59417a" 10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=22d514dbc01fdf9a9784334b6b59417a"
5 11
12DEPENDS = "zlib"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
6SRC_URI[md5sum] = "a4a38afc62ed189904357739fd8f3fb8" 15SRC_URI[md5sum] = "a4a38afc62ed189904357739fd8f3fb8"
7SRC_URI[sha256sum] = "92838e2133c9e704fdab9ee2608dad86c99021278b9ac47d065aa8ff2ea8ce36" 16SRC_URI[sha256sum] = "92838e2133c9e704fdab9ee2608dad86c99021278b9ac47d065aa8ff2ea8ce36"
17
18UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
19
20inherit autotools
21
22# Remove ccache-native's dependencies, so that it can be used widely by
23# other native recipes.
24DEPENDS_class-native = ""
25EXTRA_OECONF_class-native = "--with-bundled-zlib"
26INHIBIT_AUTOTOOLS_DEPS_class-native = "1"
27PATCHTOOL = "patch"
28
29BBCLASSEXTEND = "native"
30
31do_configure_class-native() {
32 oe_runconf
33}